[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dpkg 1.13.24 hint and next upload



On Sun, Nov 19, 2006 at 08:04:24AM +0200, Guillem Jover wrote:
> I'd like to request a hint for dpkg 1.13.24,

Hint added.

> Regarding the next and supposedly last dpkg upload before the release,
> I'd like to ask for permission to include two patches, in addition to
> the l10n and documentation fixes.

> The first patch is the one from Brendan O'Dea, that I reverted prior
> to uploading .23.

>   * Require POSIX inside subprocerr in controllib.pl. Closes: #390636

> The other one is to add lzma uncompressing support to dpkg and dpkg-dev,
> so that the archive can start accepting this kind of packages for lenny,
> otherwise we'd have to wait until lenny+1. I've been reluctant to
> add this, as the lzma's CLI was not compatible with gzip, which is now
> fixed and because supposedly the file format was going to change and
> it was not clear if backwards compatibility would be preserved,
> upstream clarified to me that the new versions are going to be able
> to extract the old format.

>   * Support extracting lzma compressed source and binary packages,
>     and add a Suggests on package lzma. Closes: #347715

> I've produced a patch for apt as well. Michael, would you accept it?
> and RMs would an apt upload be fine as well for this?

This doesn't sound disruptive to me, so that should be fine.

Thanks,
-- 
Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
vorlon@debian.org                                   http://www.debian.org/



Reply to: