[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Please remove obsolete preview-latex package (was: preview-latex: fails to install)

reassign 392863 ftp.debian.org
retitle 392863 Please remove obsolete preview-latex package

Frank Küster <frank@kuesterei.ch> wrote:

> Hi Makoto, hi Davide,
> Bill Allombert <ballombe@debian.org> wrote:
>> Package: preview-latex
>> Version: 0.9.1-4
>> Severity: serious
>> Hello Makoto,
>> There is an error when attempting to install preview-latex:
>>   install/preview-latex: Handling install for emacsen flavor emacs21
>>   emacs-install: /usr/lib/emacsen-common/packages/install/preview-latex emacs21
>> failed at /usr/lib/emacsen-common/emacs-install line 28, <TSORT> line 5.
>>   dpkg: error processing emacs21 (--configure):
>>    subprocess post-installation script returned error exit status 1

This is expected, since preview latex has been merged into auctex, and
auctex has changed internally meanwhile.

> I'm surprised that preview-latex is still there.  Isn't it completely
> replaced by auctex?
> At a short glance, it seems to me auctex should not only declare
> Conflicts and Replaces, but also Provides.  

This has now happened, auctex in sid and testing does this.

> And preview-latex should
> simply be removed from etch and sid.

ftp-masters, would you please do this?

Regards, Frank
Dr. Frank Küster
Single Molecule Spectroscopy, Protein Folding @ Inst. f. Biochemie, Univ. Zürich
Debian Developer (teTeX/TeXLive)

Reply to: