[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems with installing samba via apt-get.

I’m not sure wich list i should contact or ask for help for my problem so i hope there’s no hard feelings.

I am about to install samba with apt-get install samba and getting the following error:


apt-get install samba

Reading package lists... Done

Building dependency tree... Done

samba is already the newest version.

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

2 not fully installed or removed.

Need to get 0B of archives.

After unpacking 0B of additional disk space will be used.

Setting up samba (3.0.22-1) ...

Starting Samba daemons: nmbd failed!

invoke-rc.d: initscript samba, action "start" failed.

dpkg: error processing samba (--configure):

 subprocess post-installation script returned error exit status 1

dpkg: dependency problems prevent configuration of swat:

 swat depends on samba (= 3.0.22-1); however:

  Package samba is not configured yet.

dpkg: error processing swat (--configure):

 dependency problems - leaving unconfigured

Errors were encountered while processing:



E: Sub-process /usr/bin/dpkg returned an error code (1)


It’s the bolded lines that disturbes me because I don’t know whats wrong with it.

I’ve tried to remove samba with apt-get remove samba, and dpkg –purge samba.

I have also tried to run dpkg-reconfigure samba, but nothing seems to work.

I am very thankful if u would give me a solution that would solve my problem.

Debian r3.2 is installed on the machine and using the ‘testing’ version.




Best regards

Mattias Wiberg







Med vänliga hälsningar              


Mattias Wiberg                              


Lingongatan 31

234 43, Lomma


(Tel: 040-410226

(Mob: 0707-166804

+ WWW: http://www.google.se 

+ E-post: mattyz@ettnet.se



Reply to: