[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: sarge upgrade - linux, grub conflict

On Sun, Apr 16, 2006 at 09:59:55PM -0700, Steve Langasek wrote:
> On Mon, Apr 17, 2006 at 12:29:04AM +0200, Bastian Blank wrote:
> > For sarge updates of the linux kernels, grub needs to be updated before
> > linux-image*. Can this be forced by an conflict with older versions? A
> > dependency is not appropriate.
> Can you give more detail on why grub needs to be updated first?  I haven't
> heard anything about this incompatibilty, and would like to understand it
> before endorsing a versioned conflict; there's a very good chance that a
> versioned conflict with grub would force removal, not upgrade, of the
> bootloader.

kernel-package >> 10 uses debconf for the user communication. This
includes the pre and post scripts specified in /etc/kernel-img.conf.
update-grub from grub older than 0.97-3 writes informations to stdout,
which is coupled to debconf and makes it fail.


You're too beautiful to ignore.  Too much woman.
		-- Kirk to Yeoman Rand, "The Enemy Within", stardate unknown

Attachment: signature.asc
Description: Digital signature

Reply to: