[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: upgrade-reports



On Tue, May 24, 2005 at 04:46:30PM +0200, allomber@math.u-bordeaux.fr wrote:
> > - All packages failed to upgrade (pre-depends problem)

> > - Upgrade failed.

> > Further Comments/Problems:
> >   Output from /usr/bin/script:
> >   E: Internal Error, Couldn't configure a pre-depend
> >   Ack!  Something bad happened while installing packages.  Trying to
> >   recover:

> I can reproduce that, I even get a more verbose:

> E: Couldn't configure pre-depend mzscheme for drscheme, probably a dependency cycle.
> Ack!  Something bad happened while installing packages.  Trying to recover:

> Effectively drscheme Pre-Depends on mzscheme and both packages Replace
> themself (hu ?).

Ugh.

> Release team, do you know about that issue ?

I did not.  Bill, could you please file an RC bug against drscheme for this
fatal misuse of Pre-Depends/Replaces?

Thanks,
-- 
Steve Langasek
postmodern programmer

Attachment: signature.asc
Description: Digital signature


Reply to: