[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#301037: relocation error if an older version of libflac6 and liboggflac1 is installed

On Wed, Mar 23, 2005 at 02:47:10PM +0100, Roman Stöckl-Schmidt wrote:

> Package: flac
> Version: 1.1.1-5
> Severity: important
> If flac 1.1.1 is being installed with a version 1.1.0 of libflac6 and
> liboggflac1 already present, the flac executable will not work because
> it uses a variable which was not present in 1.1.0.
> To be precise it throws an error of "flac: relocation error: flac:
> undefined symbol: OggFLAC__FileEncoderStateString" and exists. The
> solution is to make the package flac >= 1.1.1 depend on libflac6 and
> liboggflac1 => 1.1.1.
> The following two posts from the flac mailing list archives provide
> additional information:
> http://lists.xiph.org/pipermail/flac/2005-January/000371.html
> http://lists.xiph.org/pipermail/flac/2005-March/000404.html

This is a known problem; it was discussed with the release team and decided
that the disruption of another flac soname change would cause more problems
than this bug (which is only an issue for certain partial upgrades).  So it
will wait until after Sarge.

 - mdz

Reply to: