[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: [Pkg-firebird-general] php4-interbase and classic

>Can you thing any way out of the situation? One is to provide two 
>packages - php4-interbase-(classic|super), but this is unnecessary 
>bloat. Both libfbembed (classic) and libfbclient (super) have the same 
>API, so in theory they are interchangeable. The only difference is that 
>libfbembed can connect locally.

>Other possible solution is to link php4-interbase with libgds, but make 
>ld not resolve the link on link time, so ldd shall report libgds.0, 
>which shall link to the installed library (super or classic) on runtime. 
>I don't know whether this is possible though.

>Third solution is to change libfirebird2-classic and libfirebird2-super 
>and make libgds.so hard link to the corresponding libfbembed or

>What do you think? Whick solution is doable/best?

Since the release is so close I think the best option would be to go to
something that is known to work. Which was php4-interbase 4.3.6-1 compiled
against libfirebird1.

For that to work I will need to build firebird1 packages without the server
and upload them to unstable with priority high. This will make sure
firebird-dev and libfirebird will exist in sarge again. It will close
#251458 and solve #268931 in sarge for 4.3.6-1. 

After that I will make 4.3.8-2 which links against libfirebird again, but
keep it out of sarge until we are very sure it works. This should solve
your problems for 4.3.8 (#269471)

This has the added advantage that I can document in the firebird1 packages
how to get unofficial firebird 1 packages with a server and php4-interbase
would be compatible with all version again.

After the release of sarge a more permanent solution should be found.

I'd appreciate it if somebody could find flaws in this idea.


mail2web - Check your email from the web at
http://mail2web.com/ .

Reply to: