[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Uninstallable Packages

On Tue, Dec 30, 2003 at 11:18:04PM +0900, ehikory@mail.goo.ne.jp wrote:
>     The following packages are uninstallable in eleven architectures in sarge,
> have no newer version in sid, and are not currently scheduled for removal.
> I recommend that they be scheduled for removal from testing, as:
> remove libhonyaku-damashiii-ruby/0.20-3 #depends libruby (< 1.7.0-0) vs. 1.8.0-1

There was no bug about this. I've filed one.

> remove php4-ming/0.2a.cvs10030716-2 #depends on zendapi-20020429 & not in contrib

There were bugs about this, but neither was release-critical. I've
merged them and upgraded them to grave.

> remove python-pcgi/1.999a5-3 #depends on python-bobo & not in contrib

There was no bug about this. I've filed one.

> remove vimacs/0.95-1 #depends on vim, but conflicts with current version (6.2-149+1)

There was a bug about this, but it wasn't release-critical. I've
upgraded it to grave.

>     Also, the "testing problems" output seems overzealous in marking
> packages uninstallable, as I was able to sucessfully simulate installation
> (sudo apt-get -s install foo) of the following, regardless of their also
> being listed as uninstallable on eleven architectures, including my own.
> odontolinux (0.6.1-7)
> phppgadmin (3.2.1-1)
> sourceforge (2.5-37)

The output seems quite correct; all of these packages depend on
php4-pgsql, which is indeed uninstallable in testing, since it needs a
newer version of php4. You must have a newer version of php4 installed


Colin Watson                                  [cjwatson@flatline.org.uk]

Reply to: