[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#633753: kwrite: Haskell indentation mode does not respect Haddock comments

Package: kwrite
Version: 4:4.4.5-2
Severity: normal

When editing a .hs (Haskell source) file, the Haskell indentation mode is
correctly selected.  This indentation mode will, among other things, increase
indentation when pipes appear in some places, presumably to auto-format ADT
definitions.  This is all quite desirable.

Unfortunately, the indentation mode does not check for comments preceeding the
pipe.  Haddock autodocumentation format uses the pipe to signal the difference
between an autodoc comment and a normal comment; that is,

-- |Foo

creates a Haddock comment containing the text "Foo".  The KWrite Haskell
indentation mode instead forces this to be

    -- |Foo

The Haddock User Guide (http://www.haskell.org/haddock/doc/html/index.html)
seems to indicate that the first form is correct and that the second form is

-- System Information:
Debian Release: 6.0.2
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-5-686-bigmem (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages kwrite depends on:
ii  kdebase-runtime       4:4.4.5-1          runtime components from the offici
ii  libc6                 2.11.2-10          Embedded GNU C Library: Shared lib
ii  libkdecore5           4:4.4.5-2+squeeze2 the KDE Platform Core Library
ii  libkdeui5             4:4.4.5-2+squeeze2 the KDE Platform User Interface Li
ii  libkio5               4:4.4.5-2+squeeze2 the Network-enabled File Managemen
ii  libkparts4            4:4.4.5-2+squeeze2 the Framework for the KDE Platform
ii  libktexteditor4       4:4.4.5-2+squeeze2 the KTextEditor interfaces for the
ii  libqtcore4            4:4.6.3-4+squeeze1 Qt 4 core module
ii  libqtgui4             4:4.6.3-4+squeeze1 Qt 4 GUI module
ii  libstdc++6            4.4.5-8            The GNU Standard C++ Library v3

kwrite recommends no packages.

kwrite suggests no packages.

-- no debconf information

Reply to: