[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#623258: polkit-kde: Authentication fails with correct root password

Package: polkit-kde-1
Version: 0.95.1-2+b1
Severity: important
File: polkit-kde

The KDE policy kit dialogue fails to authenticate even if I give it the correct root password. This reproduces everytime, since some time ago and makes saving NM passwords impossible.

Steps to Reproduce:
Start nm-applet, right click on its applet to get a menu, choose "edit
connections". Go to wireless tab, choose "Add" and add some data, check the
"Available to all users" box and try to save.

Two more more bugs are related to this:
1. https://bugs.launchpad.net/ubuntu/+source/policykit-gnome/+bug/500354
This seems exactly the same, but for the GNOME counter part.

Opened by me, because the same dialogue fails to tell what it wants.

-- System Information:
Debian Release: wheezy/sid
  APT prefers oldstable
  APT policy: (500, 'oldstable'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.38-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages polkit-kde-1 depends on:
ii kdebase-runtime 4:4.6.1-0r7 runtime components from the offici ii libc6 2.11.2-13 Embedded GNU C Library: Shared lib
ii  libgcc1                      1:4.6.0-3   GCC support library
ii  libkdecore5                  4:4.6.1-0r3 KDE Platform Core Library
ii libkdeui5 4:4.6.1-0r3 KDE Platform User Interface Librar
ii  libpolkit-qt-1-0             0.95.1-1    PolicyKit-qt-1 library
ii  libqt4-dbus                  4:4.7.2-3   Qt 4 D-Bus module
ii  libqt4-svg                   4:4.7.2-3   Qt 4 SVG module
ii  libqtcore4                   4:4.7.2-3   Qt 4 core module
ii  libqtgui4                    4:4.7.2-3   Qt 4 GUI module
ii  libstdc++6                   4.6.0-3     The GNU Standard C++ Library v3
ii policykit-1 0.101-3 framework for managing administrat

polkit-kde-1 recommends no packages.

polkit-kde-1 suggests no packages.

-- no debconf information

Reply to: