[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#611520: Remove Google crapware from kdebase

--- On Sun, 1/30/11, Kevin Krammer <kevin.krammer@gmx.at> wrote:

> >      Remove the following packages:
> > 1)     google-gadgets-gst
> > 2)     google-gadgets-qt
> > 3)     google-gadgets-xul
> > 4) 
>    plasma-scriptengine-googlegadgets
> > 5)     plasma-scriptengines
> So your actual wish is not to remove something from kdebase
> or any of its 
> dependencies but to have kdebase built without the Plasma
> Scriptengine for 
> Google Gadgets?
> Or to change the dependency level of plasma-scriptengines
> regarding plasma-
> scriptengine-googlegadets?

I'd go with changing the dependency level of plasma-scriptengines. I'm of the opinion that any googleware (crapware/spyware/bloatware - pick whatever you like) should not be automatically installed by the kdebase. Google gadgets are not a part of the KDE project, nor they are basic apps that anyone would need, like a text editor, a file manager and so on. 

plasma-scriptengines may RECOMMEND Google packages but they should not be automatically installed as a part of the kdebase.

I'm not even sure how I ended up with Google packages, I don't remember installing any recommended packages at all:

# aptitude why plasma-scriptengines
i   kdebase               Depends    kde-plasma-desktop (>= 5:66)        
i A kde-plasma-desktop    Depends    kdebase-workspace (>= 4:4.4.3)      
i A kdebase-workspace     Depends    kdebase-workspace-bin (>= 4:4.4.5-7)
i A kdebase-workspace-bin Recommends plasma-scriptengines 

Reply to: