[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#609749: kdelibs5-dbg: recommends kdelibs-bin of the same version, but does not depend on it

Package: kdelibs5-dbg
Version: 4:4.5.3-0r1
Severity: minor

I think kdelibs5-dbg should depend on kdelibs-bin of the same version 
instead of recommend it.  The reason being that you could get mismatched 
debug symbols if you have a system that pulls KDE from different apt 
repositories that have different KDE versions.

e.g. I went to install kdelibs5-dbg to generate a useful backtrace for a 
bug report, but the default was to install kdelibs5-dbg 4:4.4.5-2 even 
though i have kdelibs-bin 4:4.5.3-0r1 installed.

-- System Information:
Debian Release: 6.0
  APT prefers testing
  APT policy: (900, 'testing'), (800, 'unstable'), (700, 'stable'), (600, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-5-686 (SMP w/2 CPU cores)
Locale: LANG=en_AU.UTF-8, LC_CTYPE=en_AU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages kdelibs5-dbg depends on:
ii  libqt4-dbg                    4:4.6.3-4  Qt 4 library debugging symbols

Versions of packages kdelibs5-dbg recommends:
ii  kdelibs-bin                  4:4.5.3-0r1 core executables for KDE Applicati
ii  libkde3support4              4:4.5.3-0r1 the KDE 3 Support Library for the 
ii  libkdecore5                  4:4.5.3-0r1 the KDE Platform Core Library
ii  libkdesu5                    4:4.5.3-0r1 the Console-mode Authentication Li
ii  libkdeui5                    4:4.5.3-0r1 the KDE Platform User Interface Li
ii  libkdewebkit5                4:4.5.3-0r1 the KDE WebKit Library
ii  libkdnssd4                   4:4.5.3-0r1 the DNS-SD Protocol Library for th
ii  libkfile4                    4:4.5.3-0r1 the File Selection Dialog Library 
ii  libkhtml5                    4:4.5.3-0r1 the KHTML Web Content Rendering En
ii  libkimproxy4                 4:4.5.3-0r1 the Instant Messaging Interface Li
ii  libkio5                      4:4.5.3-0r1 the Network-enabled File Managemen
ii  libkjsapi4                   4:4.5.3-0r1 the KJS API Library for the KDE De
ii  libkjsembed4                 4:4.5.3-0r1 library for binding JavaScript obj
ii  libkmediaplayer4             4:4.5.3-0r1 the KMediaPlayer Interface for the
ii  libknewstuff2-4              4:4.5.3-0r1 the "Get Hot New Stuff" v2 Library
ii  libknewstuff3-4              4:4.5.3-0r1 the "Get Hot New Stuff" v3 Library
ii  libknotifyconfig4            4:4.5.3-0r1 library for configuring KDE Notifi
ii  libkntlm4                    4:4.5.3-0r1 the NTLM Authentication Library fo
ii  libkparts4                   4:4.5.3-0r1 the Framework for the KDE Platform
ii  libkpty4                     4:4.5.3-0r1 the Pseudo Terminal Library for th
ii  libkrosscore4                4:4.5.3-0r1 the Kross Core Library
ii  libkrossui4                  4:4.5.3-0r1 the Kross UI Library
ii  libktexteditor4              4:4.5.3-0r1 the KTextEditor interfaces for the
ii  libkunitconversion4          4:4.5.3-0r1 the Unit Conversion library for th
ii  libkutils4                   4:4.5.3-0r1 dummy transitional library
ii  libnepomuk4                  4:4.5.3-0r1 the Nepomuk Meta Data Library
ii  libnepomukquery4a            4:4.5.3-0r1 the Nepomuk Query Library for the 
ii  libplasma3                   4:4.5.3-0r1 the Plasma Library for the KDE Pla
ii  libsolid4                    4:4.5.3-0r1 Solid Library for KDE Platform
ii  libthreadweaver4             4:4.5.3-0r1 the ThreadWeaver Library for the K

kdelibs5-dbg suggests no packages.

Reply to: