[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#586024: kde-plasma-desktop fails to honor "user" flag for mount.cifs

Package: kde-plasma-desktop
Version: 5:62
Severity: normal

I have two mount points for cifs shares.  With the current cifs-utils, I can mount those shares as a normal user like so:

	The relevant fstab entry:

//files.ci.juneau.ak.us/james$      /home/james/G        cifs    acl,rw,user,noauto,credentials=/home/james/.nt/creds 0 0

	Mounting the share in konsole:
james@mis-jz-lnx:~$ mount G                                                                                                                                                     
james@mis-jz-lnx:~$ df -hT                                                                                                                                                      
Filesystem    Type    Size  Used Avail Use% Mounted on                                                                                                                          
/dev/sda1     ext3     73G  8.1G   61G  12% /                                                                                                                                   
tmpfs        tmpfs    1.8G  8.0K  1.8G   1% /lib/init/rw                                                                                                                        
udev         tmpfs    1.8G  220K  1.8G   1% /dev
tmpfs        tmpfs    1.8G     0  1.8G   0% /dev/shm
/dev/sdb1     ext3     37G   21G   14G  61% /home
              cifs    8.7T  5.6T  3.1T  65% /home/james/G

I have a desktop shortcut for this share, created by right clicking on the desktop, selecting create new -> link to device -> hard disk device.  Then clicking on the device tab and selecting the cifs mount from the device dropdown list.

However when I click on the resulting desktop shortcut to the device, KDE tells me that I cannot mount the share:

Could not mount device.
The reported error was:
mount: only root can do that

This definitely worked in KDE 3.5.9 (Lenny), and I seem to recall it worked in earlier versions of Squeeze before the cifs-utils package had it's suid security issue.

I expected it to work again now that cifs-utils has it's setuid behavior restored.

I'm kind of guessing as to the KDE package I should file against.  If this isn't the appropriate package please accept my apologies & push it to the correct one.

Thank you!

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages kde-plasma-desktop depends on:
ii  kdebase-apps                  4:4.4.4-1  base applications from the officia
ii  kdebase-runtime               4:4.4.4-1  runtime components from the offici
ii  kdebase-workspace             4:4.4.4-1  base workspace components from the
ii  plasma-desktop                4:4.4.4-1  The KDE Plasma workspace for deskt

Versions of packages kde-plasma-desktop recommends:
ii  kdm                           4:4.4.4-1  KDE Display Manager for X11
ii  xserver-xorg                  1:7.5+6    the X.Org X server

Versions of packages kde-plasma-desktop suggests:
pn  kde-l10n                      <none>     (no description available)

-- no debconf information

Reply to: