[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#582953: kmail deleted all non-local incoming mail settings on upgrade

Package: kmail
Version: 4:4.4.3-1
Severity: critical
Tags: squeeze sid
Justification: causes serious data loss

Kmail is running with dimap, imap, imap and pop3 accounts. All is well. I run
aptitude safe-upgrade. Upon next login and start of kmail, all the said accounts
are gone from the settings.

During this startup of kmail (and the corresponding startup
of akonadi), there were numerous messages about unreadable mail folders. These happened
to be folders of the dimap account, but I suspect that is simply coincidence: kmail 
listed the folders first and someone destroyed them before kmail actually accessed them.
This makes me wonder if akonadi is the real culprit here, after all, but I have no way
of finding out. The safe-upgrade did not update kmail, but it did update akonadi-server.

Critical: data loss: if pop3 account emails are on local disc instead of the server,
those messages are lost.


-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.34 (SMP w/2 CPU cores)
Locale: LANG=C, LC_CTYPE=C (charmap=UTF-8) (ignored: LC_ALL set to en_GB.UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages kmail depends on:
ii  kdebase-runtime     4:4.4.3-1            runtime components from the offici
ii  kdepim-runtime      4:4.4.3-1            Runtime components for akonadi-kde
ii  kdepimlibs-kio-plug 4:4.4.3-1            kio slaves used by KDE PIM applica
ii  libakonadi-contact4 4:4.4.3-1            library for using the Akonadi PIM 
ii  libakonadi-kde4     4:4.4.3-1            library for using the Akonadi PIM 
ii  libc6               2.10.2-9             Embedded GNU C Library: Shared lib
ii  libgcc1             1:4.4.4-2            GCC support library
ii  libgpgme++2         4:4.4.3-1            c++ wrapper library for gpgme
ii  libkabc4            4:4.4.3-1            library for handling address book 
ii  libkcal4            4:4.4.3-1            library for handling calendar data
ii  libkde3support4     4:4.4.3-2            the KDE 3 Support Library for the 
ii  libkdecore5         4:4.4.3-2            the KDE Platform Core Library
ii  libkdepim4          4:4.4.3-1            KDE PIM library
ii  libkdeui5           4:4.4.3-2            the KDE Platform User Interface Li
ii  libkhtml5           4:4.4.3-2            the KHTML Web Content Rendering En
ii  libkimap4           4:4.4.3-1            library for handling IMAP data
ii  libkio5             4:4.4.3-2            the Network-enabled File Managemen
ii  libkldap4           4:4.4.3-1            library for accessing LDAP
ii  libkleo4            4:4.4.3-1            certificate based crypto library f
ii  libkmime4           4:4.4.3-1            library for handling MIME data
ii  libknotifyconfig4   4:4.4.3-2            library for configuring KDE Notifi
ii  libkontactinterface 4:4.4.3-1            Kontact interface library
ii  libkparts4          4:4.4.3-2            the Framework for the KDE Platform
ii  libkpgp4            4:4.4.3-1            gpg based crypto library for KDE
ii  libkpimidentities4  4:4.4.3-1            library for managing user identiti
ii  libkpimtextedit4    4:4.4.3-1            library that provides a textedit w
ii  libkpimutils4       4:4.4.3-1            library for dealing with email add
ii  libkresources4      4:4.4.3-1            the KDE Resource framework library
ii  libksieve4          4:4.4.3-1            KDE mail/news message filtering li
ii  libktnef4           4:4.4.3-1            library for handling TNEF data
ii  libkutils4          4:4.4.3-2            various utility classes for the KD
ii  libmailtransport4   4:4.4.3-1            mail transport service library
ii  libmessagecore4     4:4.4.3-1            message core library for KDE
ii  libmessagelist4     4:4.4.3-1            message list library for KDE
ii  libmimelib4         4:4.4.3-1            KDE MIME library
ii  libnepomuk4         4:4.4.3-2            the Nepomuk Meta Data Library
ii  libphonon4          4:4.6.0really4.4.1-2 the core library of the Phonon mul
ii  libqt4-dbus         4:4.6.2-5            Qt 4 D-Bus module
ii  libqt4-network      4:4.6.2-5            Qt 4 network module
ii  libqt4-qt3support   4:4.6.2-5            Qt 3 compatibility library for Qt 
ii  libqt4-xml          4:4.6.2-5            Qt 4 XML module
ii  libqtcore4          4:4.6.2-5            Qt 4 core module
ii  libqtgui4           4:4.6.2-5            Qt 4 GUI module
ii  libstdc++6          4.4.4-2              The GNU Standard C++ Library v3
ii  libthreadweaver4    4:4.4.3-2            the ThreadWeaver Library for the K
ii  perl                5.10.1-12            Larry Wall's Practical Extraction 
ii  phonon              4:4.6.0really4.4.1-2 metapackage for the Phonon multime

kmail recommends no packages.

Versions of packages kmail suggests:
pn  clamav | f-prot-installer     <none>     (no description available)
ii  gnupg                         1.4.10-3   GNU privacy guard - a free PGP rep
ii  gnupg-agent                   2.0.14-1.1 GNU privacy guard - password agent
ii  gnupg2                        2.0.14-1.1 GNU privacy guard - a free PGP rep
ii  kaddressbook                  4:4.4.3-1  KDE address book
ii  kleopatra                     4:4.4.3-1  KDE Certificate Manager
ii  pinentry-qt4 [pinentry-x11]   0.8.0-1    Qt-4-based PIN or pass-phrase entr
ii  procmail                      3.22-19    Versatile e-mail processor
ii  spambayes                     1.0.4-5.1  Python-based spam filter using sta

-- no debconf information

Reply to: