[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#578890: marked as done (libqt4-opengl: stellarium completely broken with qt 4.6, fine with 4.5)

Your message dated Sat, 24 Apr 2010 13:03:56 +0000
with message-id <E1O5f1Y-0004Y1-CL@ries.debian.org>
and subject line Bug#578890: fixed in stellarium 0.10.4-0.1
has caused the Debian Bug report #578890,
regarding libqt4-opengl: stellarium completely broken with qt 4.6, fine with 4.5
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

578890: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=578890
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: libqt4-opengl
Version: 4:4.6.2-4
Severity: important

stellarium is completely broken with qt 4.6.  I confirmed that
downgrading to 4.5 fixed it.  With 4.6, I get lots of
'StelAppGraphicsScene: drawBackground needs a QGLWidget to be set as
viewport on the graphics view' messages in the terminal, and most of the
stellarium window is black, except for menus.  But even menus get
redrawn over themselves so are unreadable.

This happens for me on the swrast and i965 mesa drivers, and for another
user on nvidia's blob.

Cc: to the stellarium maintainer.


-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (101, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-4-amd64 (SMP w/2 CPU cores)
Locale: LANG=C, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages libqt4-opengl depends on:
ii  libc6                         2.10.2-6   Embedded GNU C Library: Shared lib
ii  libfreetype6                  2.3.11-1   FreeType 2 font engine, shared lib
ii  libgcc1                       1:4.4.3-9  GCC support library
ii  libgl1-mesa-glx [libgl1]      7.7.1-1    A free implementation of the OpenG
ii  libqtcore4                    4:4.5.3-4  Qt 4 core module
ii  libqtgui4                     4:4.5.3-4  Qt 4 GUI module
ii  libstdc++6                    4.4.3-9    The GNU Standard C++ Library v3
ii  libx11-6                      2:1.3.3-3  X11 client-side library

libqt4-opengl recommends no packages.

libqt4-opengl suggests no packages.

-- no debconf information

Attachment: signature.asc
Description: Digital signature

--- End Message ---
--- Begin Message ---
Source: stellarium
Source-Version: 0.10.4-0.1

We believe that the bug you reported is fixed in the latest version of
stellarium, which is due to be installed in the Debian FTP archive:

  to main/s/stellarium/stellarium-data_0.10.4-0.1_all.deb
  to main/s/stellarium/stellarium_0.10.4-0.1.debian.tar.gz
  to main/s/stellarium/stellarium_0.10.4-0.1.dsc
  to main/s/stellarium/stellarium_0.10.4-0.1_amd64.deb
  to main/s/stellarium/stellarium_0.10.4.orig.tar.gz

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 578890@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Fathi Boudra <fabo@debian.org> (supplier of updated stellarium package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Sat, 24 Apr 2010 10:44:18 +0300
Source: stellarium
Binary: stellarium stellarium-data
Architecture: source amd64 all
Version: 0.10.4-0.1
Distribution: unstable
Urgency: low
Maintainer: Cédric Delfosse <cedric@debian.org>
Changed-By: Fathi Boudra <fabo@debian.org>
 stellarium - real-time photo-realistic sky generator
 stellarium-data - Stellarium data files
Closes: 482889 530315 570005 577985 578890
 stellarium (0.10.4-0.1) unstable; urgency=low
   * Non-maintainer upload - acked by the maintainer
   * New upstream release (Closes: #570005, #577985)
   * Switch to dpkg-source 3.0 (quilt) format
   * Add 01_fix_pow10_function_check.diff:
     pow10 function check fails as we don't link against math library
   * Add 02_remove_unknown_locale_code.diff:
     remove nan locale code, it is unknown
   * Bump debian/compat from 5 to 7
   * Update debian/control:
     - bump debhelper build dependency to 7.4.15 for dh usage
     - cleanup build dependencies (keep libqt4*-dev and add zlib1g-dev)
     - add versioned build dependencies to cmake (>= 2.6.0)
     - add versioned build dependencies to libqt4-dev (>= 4.6.0)
       (Closes: #578890)
     - bump Standards-Version to 3.8.0 to 3.8.4 (no changes needed)
     - relax dependency relation between stellarium and stellarium-data
       (Closes: #482889)
     - add missing ${misc:Depends} to stellarium-data, lintian warning--
     - remove stellarium (<< 0.6.2-1) Replaces, it's not needed anymore
     - cleanup stellarium-data description, lintian warning--
   * Update debian/copyright:
     - cleanup layout
     - update copyright information
   * Update debian/rules:
     - convert to dh usage
     - enable parallel build (pass --parallel option to dh)
     - list missing files (pass --list-missing option to dh)
   * Update debian/stellarium.desktop (Closes: #530315):
     - remove encoding key, deprecated
     - add missing list separator to categories key
   * Add debian/watch file.
 6a65c02a4057e81a0e2d7852c4e45acc03da3e1b 1291 stellarium_0.10.4-0.1.dsc
 8a9f22da5a0049ea10b19b24d28490dc15dea1a8 36129866 stellarium_0.10.4.orig.tar.gz
 1a89cce1032eb20292d8d852f735d1d869fd64bd 18310 stellarium_0.10.4-0.1.debian.tar.gz
 2ec62acf8bab3b9dbe7d21069617bd5bdefc65ec 3126814 stellarium_0.10.4-0.1_amd64.deb
 0d1e4426f785abbd1458f3b008024dcb0f48a196 32320360 stellarium-data_0.10.4-0.1_all.deb
 91ce93efc553870b32d46b2291616af29d3f0cd534ac5dce373eab7191652fbf 1291 stellarium_0.10.4-0.1.dsc
 afdd9376f2e36e9e56575516e2a8203b8091588e7236d9e595b4fc9c4ae668df 36129866 stellarium_0.10.4.orig.tar.gz
 0dd75b353c74d0e3ff3a589a7761fd3d96a14d3252f7ed105b561eebe4ca94d0 18310 stellarium_0.10.4-0.1.debian.tar.gz
 db8a37b13a09f86d4ed34e543cb116e833189072588636f33668d78501518124 3126814 stellarium_0.10.4-0.1_amd64.deb
 a7a0f4e1ecc1b8b0c3bcc66c50a117533a4a23dee5222ec6c9dcef632207ed45 32320360 stellarium-data_0.10.4-0.1_all.deb
 c46e7d8913653be30d033f265fc18f7f 1291 science optional stellarium_0.10.4-0.1.dsc
 ebb81f609c91be6ecd7e91cf7d3a4afa 36129866 science optional stellarium_0.10.4.orig.tar.gz
 61bb35e1711357e9ee81b61df3afd117 18310 science optional stellarium_0.10.4-0.1.debian.tar.gz
 9153632fab784e55f5aae4d273a3173a 3126814 science optional stellarium_0.10.4-0.1_amd64.deb
 696be610bae7da92e0718ceaee9a2f00 32320360 science optional stellarium-data_0.10.4-0.1_all.deb

Version: GnuPG v1.4.10 (GNU/Linux)


--- End Message ---

Reply to: