[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#423438: marked as done (kdelibs4c2a: cupsdoprint -P 'Mail PDF File' execution failed with message: client-error-not-found)

Your message dated Thu, 11 Mar 2010 21:08:43 -0500
with message-id <9f694b821003111808y7ed718c8i7300972462a2dc3c@mail.gmail.com>
and subject line Closing bug # 423438
has caused the Debian Bug report #423438,
regarding kdelibs4c2a: cupsdoprint -P 'Mail PDF File' execution failed with message: client-error-not-found
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

423438: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=423438
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: kdelibs4c2a
Version: 4:3.5.6.r1.dfsg.1-4
Severity: normal

I think we might have a regression issue fixed in BTS #370403?

Upgraded to cupsys-1.2.7-4 and "lost" my "Mail PDF File" and "Print to File
(PDF") printers.

Digging around I found BTS #370403. Tried all the recommend hacks, including
'apt-get remove --purge cupsys', rebooting, restart X, etc.

Attempting a test print to the "Mail PDF File" printer via Control Center GUI I
get a Catastrophe! KNotify

cupsdoprint -P 'Mail PDF File' -J '' -H '/var/run/cups/cups.sock:631' -U 'tanner' -o ' multiple-document-handling=separate-documents-uncollated-copies orientation-requested=3' '/usr/share/apps/kdeprint/testprint.ps' : execution failed with message: client-error-not-found

Same error message via the command line.

Looks like some sort of upgrade/conf issue, but I cannot seem to find where.

Cups reports back that "Mail PDF File" is not a valid printer. But I have never
had to do anything special to get the "Mail PDF File" printer working before.

d [11/May/2007:15:14:03 -0500] POST /printers/Mail PDF File
d [11/May/2007:15:14:03 -0500] CONTENT_TYPE = application/ipp
d [11/May/2007:15:14:03 -0500] cupsdReadClient: 8 con->data_encoding=HTTP_ENCODE
_LENGTH, con->data_remaining=14849, con->file=-1
d [11/May/2007:15:14:03 -0500] cupsdReadClient: 8 REQUEST /var/spool/cups/000000
d [11/May/2007:15:14:03 -0500] cupsdReadClient: 8 writing 14521 bytes to 9
d [11/May/2007:15:14:03 -0500] cupsdReadClient: 8 Closing data file 9, size=1452
d [11/May/2007:15:14:03 -0500] cupsdProcessIPPRequest(0x5a3010[8]): operation_id
 = 0002
D [11/May/2007:15:14:03 -0500] Print-Job ipp://localhost/printers/Mail%20PDF%20F
d [11/May/2007:15:14:03 -0500] print_job(0x5a3010[8], ipp://localhost/printers/M
D [11/May/2007:15:14:03 -0500] print_job: auto-typing file...
D [11/May/2007:15:14:03 -0500] print_job: request file type is application/posts
d [11/May/2007:15:14:03 -0500] add_job(0x5a3010[8], ipp://localhost/printers/Mai
D [11/May/2007:15:14:03 -0500] Print-Job client-error-not-found: The printer or
class was not found.

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (500, 'testing'), (500, 'stable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.20-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=ISO-8859-1)
Shell: /bin/sh linked to /bin/bash

Versions of packages kdelibs4c2a depends on:
ii  kdelibs- 4:3.5.6.r1.dfsg.1-4             core shared data for all KDE appli
ii  libacl1  2.2.42-1                        Access control list shared library
ii  libart-2 2.3.19-3                        Library of functions for 2D graphi
ii  libarts1 1.5.6-2                         aRts sound system core components
ii  libasoun 1.0.13-2                        ALSA library
ii  libaspel 0.60.5-1                        GNU Aspell spell-checker runtime l
ii  libattr1 1:2.4.32-1.1                    Extended attribute shared library
ii  libaudio 1.9-2                           The Network Audio System (NAS). (s
ii  libavahi 0.6.18-5                        Avahi client library
ii  libavahi 0.6.18-5                        Avahi common library
ii  libavahi 0.6.18-5                        Avahi Qt3 integration library
ii  libbz2-1 1.0.3-6                         high-quality block-sorting file co
ii  libc6    2.5-7                           GNU C Library: Shared libraries
ii  libcomer 1.39+1.40-WIP-2007.04.07+dfsg-2 common error description library
ii  libcupsy 1.2.7-4                         Common UNIX Printing System(tm) - 
ii  libfam0  2.7.0-12                        Client library to control the FAM 
ii  libfontc 2.4.2-1.2                       generic font configuration library
ii  libfreet 2.2.1-5                         FreeType 2 font engine, shared lib
ii  libgcc1  1:4.1.2-6                       GCC support library
ii  libgnutl 1.6.2-1                         the GNU TLS library - runtime libr
ii  libice6  1:1.0.3-2                       X11 Inter-Client Exchange library
ii  libidn11 0.6.5-1                         GNU libidn library, implementation
ii  libjaspe 1.900.1-3                       The JasPer JPEG-2000 runtime libra
ii  libjpeg6 6b-13                           The Independent JPEG Group's JPEG 
ii  libkrb53 1.6.dfsg.1-3                    MIT Kerberos runtime libraries
ii  liblua50 5.0.3-2                         Main interpreter library for the L
ii  libluali 5.0.3-2                         Extension library for the Lua 5.0 
ii  libopene 1.2.2-4.3                       runtime files for the OpenEXR imag
ii  libpcre3 6.7-1                           Perl 5 Compatible Regular Expressi
ii  libpng12 1.2.15~beta5-1                  PNG library - runtime
ii  libqt3-m 3:3.3.7-4+b1                    Qt GUI Library (Threaded runtime v
ii  libsm6   1:1.0.2-2                       X11 Session Management library
ii  libstdc+ 4.1.2-6                         The GNU Standard C++ Library v3
ii  libtiff4 3.8.2-7                         Tag Image File Format (TIFF) libra
ii  libx11-6 2:1.0.3-7                       X11 client-side library
ii  libxcurs 1:1.1.8-2                       X cursor management library
ii  libxext6 1:1.0.3-2                       X11 miscellaneous extension librar
ii  libxft2  2.1.12-2                        FreeType-based font drawing librar
ii  libxi6   1:1.0.1-4                       X11 Input extension library
ii  libxiner 1:1.0.2-1                       X11 Xinerama extension library
ii  libxml2  2.6.28.dfsg-1                   GNOME XML library
ii  libxrand 2:1.2.1-1                       X11 RandR extension library
ii  libxrend 1:0.9.2-1                       X Rendering Extension client libra
ii  libxslt1 1.1.20-1                        XSLT processing library - runtime 
ii  libxt6   1:1.0.5-2                       X11 toolkit intrinsics library
ii  menu-xdg 0.2.3                           freedesktop.org menu compliant win
ii  perl     5.8.8-7                         Larry Wall's Practical Extraction 
ii  xbase-cl 1:7.2.ds2-2                     miscellaneous X clients
ii  zlib1g   1:1.2.3-13                      compression library - runtime

Versions of packages kdelibs4c2a recommends:
pn  perl-suid                     <none>     (no description available)

-- no debconf information

--- End Message ---
--- Begin Message ---
No answer from submitter since a long time
Closing this bug report

--- End Message ---

Reply to: