[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#572493: qtcreator: starts very slowly with qt 4.6.2-1 from experimental


I did some testing and I think that this delay is related to rebuilding
of help index (probably triggered by qt update).

I can easily reproduce this bug by removing file
~/.config/Nokia/qtcreator/helpcollection.qhc and running qtcreator. Then
I have to wait several minutes for the main window. strace also showed
that qtcreator writes to this file at that time (at leas some threads).

I do not know why qtcreator also terminates very slowly after that.

Passing "-noload Help" makes startup fast, but then there is no help :(.

I cannot yet find a good way to make it start fast again. I did this
once (by removing some files under ~/.config several times in different
order) but cannot do this now :(.

4 березня 2010 о 18:30 -0600 Adam Majer написав(-ла):
> On Thu, Mar 04, 2010 at 03:31:02PM +0100, Євгеній Мещеряков wrote:
> > Package: qtcreator
> > Version: 1.3.1-1
> > Severity: normal
> > 
> > After upgrading to qt 4.6.2-1 qtcreator takes long time (several minutes) to
> > start. Usually it took only 1-2 seconds to start.
> I *think* I've seen something about this in some changes. I suspect
> this may have something to do with DNS resolution and/or RSS feed.
> Can you try how long it takes to startup if you stop your network
> connection?
Nothing changes if the computer has no network connection.

Eugeniy Meshcheryakov

Attachment: signature.asc
Description: Digital signature

Reply to: