[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#572786: plasmapkg: no way to find out which options the argument --type can handle

Package: kdebase-runtime
Version: 4:4.3.4-2
Severity: normal


  $ plasmapkg --help | grep type
  -t, --type <type>         The type of package, e.g. theme, wallpaper, plasmoid, dataengine, runner, etc. [plasmoid]

I find it hard to understand what --type options are available. I can only make assumptions about each proposed option keyword. And I have no clue what "etc" refers to.

It's even harder in french because the options keywords have been translated.

  $ plasmapkg --help | grep type
  -t, --type <type>         Le type du paquetage, par exemple thème, fond d'écran, plasmoïde, dataengine, runner, etc. [plasmoid]

 The translated options keywords works (you can really use --type "fond d'écran") but that's unusual enough to puzzle me. For instance, I still use plasmapkg --help, not plasmapkg --aide, plasmapkg --upgrade instead of plasma --met-à-jour, etc. 
So I wonder if the idea of translating this option does not even make the overall more obscure. Not to mention the fact that is makes the issue harder to google about. There was a discussion on org.kde.kde-i18n-doc about it (http://markmail.org/message/iwm3xcblbgklciyc), I think it has been a bold move to make these options keywords translatable without looking at the big picture.

  $ man plasmapkg
No manual entry for plasmapkg
See 'man 7 undocumented' for help when manual pages are not available.


So, what "etc" stands for? What does exactly theme refers to? Superkaramba ones?

I understand there may be too separate issue here (1/ the lack of documentation of the --type option, 2/ the idea to translate option keywords), please feel free to duplicate if necessary.


-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-trunk-amd64 (SMP w/2 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages kdebase-runtime depends on:
ii  kdebase-runtime-data      4:4.3.4-2      shared data files for the KDE 4 ba
ii  kdelibs5                  4:4.3.4-3      core libraries for all KDE 4 appli
ii  libasound2                1.0.22-2       shared library for ALSA applicatio
ii  libc6                     2.10.2-6       Embedded GNU C Library: Shared lib
ii  libclucene0ldbl           0.9.21b-2+b1   library for full-featured text sea
ii  libgcc1                   1:4.4.3-3      GCC support library
ii  libjpeg62                 6b-16.1        The Independent JPEG Group's JPEG 
ii  libknotificationitem-1-1  4:4.3.4-1      library for new way of handling sy
ii  libopenexr6               1.6.1-4.1      runtime files for the OpenEXR imag
ii  libphonon4                4:4.5.3-4      Qt 4 Phonon module
ii  libplasma3                4:4.3.4-3      library for the KDE 4 Plasma deskt
ii  libpulse0                 0.9.21-1       PulseAudio client libraries
ii  libqt4-dbus               4:4.5.3-4      Qt 4 D-Bus module
ii  libqt4-qt3support         4:4.5.3-4      Qt 3 compatibility library for Qt 
ii  libqt4-svg                4:4.5.3-4      Qt 4 SVG module
ii  libqt4-xml                4:4.5.3-4      Qt 4 XML module
ii  libqtcore4                4:4.5.3-4      Qt 4 core module
ii  libqtgui4                 4:4.5.3-4      Qt 4 GUI module
ii  libsmbclient              2:3.4.6~dfsg-1 shared library for communication w
ii  libsoprano4               2.4.1+dfsg.1-1 libraries for the Soprano RDF fram
ii  libstdc++6                4.4.3-3        The GNU Standard C++ Library v3
ii  libstreamanalyzer0        0.7.1-1        streamanalyzer library for Strigi 
ii  libstreams0               0.7.1-1        streams library for for Strigi Des
ii  libx11-6                  2:1.3.3-1      X11 client-side library
ii  libxcursor1               1:1.1.10-1     X cursor management library
ii  libxine1                  1.1.17-1+b1    the xine video/media player librar
ii  oxygen-icon-theme         4:4.3.4-1      Oxygen icon theme
ii  phonon-backend-gstreamer  4:4.3.1-5      Phonon GStreamer 0.10.x backend
ii  phonon-backend-xine [phon 4:4.3.1-5      Phonon Xine 1.1.x backend

Versions of packages kdebase-runtime recommends:
ii  hal                           0.5.14-2   Hardware Abstraction Layer
ii  pmount                        0.9.20-2   mount removable devices as normal 

Versions of packages kdebase-runtime suggests:
pn  djvulibre-bin                 <none>     (no description available)

-- no debconf information

Reply to: