[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#413055: marked as done (kdelibs4c2a: KDE widget that accepts password behaves wrong when keyboard layout is not US)

Your message dated Sun, 21 Feb 2010 15:52:54 +0100
with message-id <201002211552.54261.ewoerner@kde.org>
and subject line Re: kdelibs4c2a: KDE widget that accepts password behaves wrong when keyboard layout is not US
has caused the Debian Bug report #413055,
regarding kdelibs4c2a: KDE widget that accepts password behaves wrong when keyboard layout is not US
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

413055: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=413055
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: kdelibs4c2a
Version: 4:3.5.5a.dfsg.1-6
Severity: important
Tags: l10n

I have configured my keyboard for two layouts "us" and "ru". If I switch keyboard to "ru" layout
and KDE dialog prompting password appears then for every character I type into password field
two asteriks appear. To reproduce it, you can run Control Center and in any administration applet
click appropriate button to switch into admin mode and when dialog prompting root password
appears switch the layout to different language and try to type something. Another way to
reproduce it is KDE lock screen: try to enter password there with switched layout.

Plain Qt programs do not suffer from this bug. Checked on Psi.

I suspect that problem is with UTF-8, i.e. entering a two-byte UTF-8 character displays two "*".

-- System Information:
Debian Release: 4.0
  APT prefers testing
  APT policy: (500, 'testing'), (200, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-3-686
Locale: LANG=ru_RU.UTF-8, LC_CTYPE=ru_RU.UTF-8 (charmap=UTF-8)

Versions of packages kdelibs4c2a depends on:
ii  kdelibs- 4:3.5.5a.dfsg.1-6               core shared data for all KDE appli
ii  libacl1  2.2.41-1                        Access control list shared library
ii  libart-2 2.3.17-1                        Library of functions for 2D graphi
ii  libarts1 1.5.5-1                         aRts sound system core components
ii  libasoun 1.0.13-1                        ALSA library
ii  libaspel 0.60.4-4                        GNU Aspell spell-checker runtime l
ii  libattr1 2.4.32-1                        Extended attribute shared library
ii  libaudio 1.8-3                           The Network Audio System (NAS). (s
ii  libavahi 0.6.16-2                        Avahi client library
ii  libavahi 0.6.16-2                        Avahi common library
ii  libavahi 0.6.16-2                        Avahi Qt3 integration library
ii  libbz2-1 1.0.3-6                         high-quality block-sorting file co
ii  libc6    2.3.6.ds1-11                    GNU C Library: Shared libraries
ii  libcomer 1.39+1.40-WIP-2006.11.14+dfsg-1 common error description library
ii  libcupsy 1.2.7-4                         Common UNIX Printing System(tm) - 
ii  libfontc 2.4.2-1                         generic font configuration library
ii  libfreet 2.2.1-5                         FreeType 2 font engine, shared lib
ii  libgamin 0.1.8-1                         Client library for the gamin file 
ii  libgcc1  1:4.1.1-21                      GCC support library
ii  libgnutl 1.4.4-3                         the GNU TLS library - runtime libr
ii  libice6  1:1.0.1-2                       X11 Inter-Client Exchange library
ii  libidn11 0.6.5-1                         GNU libidn library, implementation
ii  libjaspe 1.701.0-2                       The JasPer JPEG-2000 runtime libra
ii  libjpeg6 6b-13                           The Independent JPEG Group's JPEG 
ii  libkrb53 1.4.4-6                         MIT Kerberos runtime libraries
ii  liblua50 5.0.3-2                         Main interpreter library for the L
ii  libluali 5.0.3-2                         Extension library for the Lua 5.0 
ii  libopene 1.2.2-4.3                       runtime files for the OpenEXR imag
ii  libpcre3 6.7-1                           Perl 5 Compatible Regular Expressi
ii  libpng12 1.2.15~beta5-1                  PNG library - runtime
ii  libqt3-m 3:3.3.7-3                       Qt GUI Library (Threaded runtime v
ii  libsm6   1:1.0.1-3                       X11 Session Management library
ii  libstdc+ 4.1.1-21                        The GNU Standard C++ Library v3
ii  libtiff4 3.8.2-7                         Tag Image File Format (TIFF) libra
ii  libx11-6 2:1.0.3-5                       X11 client-side library
ii  libxcurs 1.1.7-4                         X cursor management library
ii  libxext6 1:1.0.1-2                       X11 miscellaneous extension librar
ii  libxft2                       FreeType-based font drawing librar
ii  libxi6   1:1.0.1-4                       X11 Input extension library
ii  libxiner 1:1.0.1-4.1                     X11 Xinerama extension library
ii  libxml2  2.6.27.dfsg-1                   GNOME XML library
ii  libxrand 2:                     X11 RandR extension library
ii  libxrend 1:0.9.1-3                       X Rendering Extension client libra
ii  libxslt1 1.1.19-1                        XSLT processing library - runtime 
ii  libxt6   1:1.0.2-2                       X11 toolkit intrinsics library
ii  menu-xdg 0.2.3                           freedesktop.org menu compliant win
ii  perl     5.8.8-7                         Larry Wall's Practical Extraction 
ii  xbase-cl 1:7.1.ds1-2                     miscellaneous X clients
ii  zlib1g   1:1.2.3-13                      compression library - runtime

Versions of packages kdelibs4c2a recommends:
pn  perl-suid                     <none>     (no description available)

-- no debconf information

--- End Message ---
--- Begin Message ---
Version: 4:4.2.2-1

The bug you reported has been fixed in KDE SC 4.2.2

--- End Message ---

Reply to: