[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SystemSettings

On Thu, Jan 7, 2010 at 4:25 AM, Peter Besenbruch <prb@lava.net> wrote:
> Two items, possibly related:
> System Settings crashes when clicking on System and PolicyKit authorization.
> Crashing is instant and happens every time.

Installing the policykit package will fix the crash, but since
policykit is deprecated now in favor of policykit-1, there is noting
useful you can do with this systemsettings module. It will probably be
removed from the debian packages in kde 4.4, since it hasn't been
ported yet to policykit-1.

> System settings will not run as administrator. By that I mean it will not run
> with Gksu from a menu, or from a root terminal (with xhost set properly).

Works for me: "su-to-root -X -c systemsettings". If this still doesn't
work, try "dbus-launch systemsettings" from a root terminal.

> I ran across these bugs when trying to run programs as a different user (which
> also doesn't work).
> KDE version 4.3.4-1.

PS: Note that this is not the correct mailing list for such questions.
The correct one is debian-kde@lists.debian.org. If you have any more
questions, please ask there.

Reply to: