[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#553118: kweather: postinst-must-call-ldconfig /usr/lib/libkdeinit4_kweatherreport.so by the dynamic library loader. Therefore, the package must call "ldconfig" in its postinst script.

Package: kweather
Version: 4:4.3.2-1
Severity: serious
Justification: The package installs shared libraries in a directory controlled
User: lintian-maint@debian.org
Usertags: postinst-must-call-ldconfig

Refer to Debian Policy Manual section 8.1.1 (ldconfig) for details. 

,----[ 8.1.1 ldconfig ]
| Any package installing shared libraries in one of the default library
| directories of the dynamic linker (which are currently /usr/lib and /lib) or a
| directory that is listed in /etc/ld.so.conf[47] must use ldconfig to update the
| shared library system.
| The package maintainer scripts must only call ldconfig under these circumstances:
|  * When the postinst script is run with a first argument of configure, the
|    script must call ldconfig, and may optionally invoke ldconfig at other times.
|  * When the postrm script is run with a first argument of remove, the script
|    should call ldconfig.


-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (500, 'oldstable'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8) (ignored: LC_ALL set to en_US.UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages kweather depends on:
ii  kdebase-runtime               4:4.3.2-1  runtime components from the offici
ii  kdelibs5                      4:4.3.2-2  core libraries for all KDE 4 appli
ii  libc6                         2.10.1-2   GNU C Library: Shared libraries
ii  libqt4-dbus                   4:4.5.3-4  Qt 4 D-Bus module
ii  libqt4-qt3support             4:4.5.3-4  Qt 3 compatibility library for Qt 
ii  libqtcore4                    4:4.5.3-4  Qt 4 core module
ii  libqtgui4                     4:4.5.3-4  Qt 4 GUI module
ii  libstdc++6                    4.4.2-1    The GNU Standard C++ Library v3

kweather recommends no packages.

kweather suggests no packages.

Reply to: