[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Some KDE libs still use .kde4 instead of .kde?


While trying to track down a completely separate problem/bug I ran this 
strace konqueror 2>&1 |grep "open"|sort|uniq|less
and discovered these interesting lines:
open("/home/brendon/.icons/crystalwhite/cursors/left_ptr", O_RDONLY) = -1 
ENOENT (No such file or directory)
open("/home/brendon/.icons/crystalwhite/index.theme", O_RDONLY) = -1 ENOENT 
(No such file or directory)
open("/home/brendon/.kde4/share/config/kdeglobals", O_RDONLY) = 8
open("/home/brendon/.kde4/share/config/kdeglobals", O_RDONLY) = 9
open("/home/brendon/.kde/share/apps/khtml/khtml_browser.rc", O_RDONLY) = 12
O_RDONLY) = 12

Why is it opening files in .kde4 *and* .kde? Correct me if I'm wrong, but I was 
under the impression that the .kde4 to .kde transition had already taken place 
(c.f. kaboom). It seems, perhaps, the KDE globals library is still using 
configuration in the .kde4 folder. This doesn't sound right to me.

I tried to search this mailing list, though it's hard to find relevant results 
when the search algorithm ignores your pleas to *really include* the dot in 
".kde". I'm wondering if I should file a bug, or if this behaviour is somehow 
expected (perhaps due to some configuration option I'm unaware of)?

Not subscribed, please CC. :-)


Reply to: