[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#530108: kde-l10n-nn: bashism in /bin/sh script

Package: kde-l10n-nn
Severity: important
Version: 4:4.2.2-1
User: debian-release@lists.debian.org
Usertags: goal-dash

Hello maintainer,

While performing an archive wide checkbashisms (from the 'devscripts' package)
check I've found your package containing a /bin/sh script making use
of a bashism.

checkbashisms' output:
> possible bashism in ./usr/share/locale/nn/LC_SCRIPTS/kdelibs4/oppdater.sh
> line 37 (echo -e):
> echo -e '\n\n'
> possible bashism in ./usr/share/locale/nn/LC_SCRIPTS/kdelibs4/oppdater.sh
> line 44 (should be 'b = a'):
>   if [ "$tooold" == 0 ]

Not using bash (or a Debian Policy conformant shell interpreter which doesn't
provide such an extra feature) as /bin/sh is likely to lead to errors or
unexpected behaviours.
Please be aware that although bash is currently the default /bin/sh there was
a release goal for Lenny to make dash the default /bin/sh[1], and has been
proposed for squeeze as well[2].

If you want more information about dash as /bin/sh, you can read:

For more information supporting this goal please refer to Debian Policy,
section 10.4, at:

Hints about how to fix bashisms:
Sometimes these bugs are already fixed in Ubuntu, look at the PTS.
If not already fixed you can read:

If you still don't know how to fix the bashisms don't hesitate to reply to
this email, or tag the bug as 'help'.


Thank you,
Raphael Geissert

Reply to: