[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#526979: konqueror: cannot import SSL root certificates

Package: konqueror
Version: 4:4.2.2-1
Severity: important


Since upgrading from 3.5 to 4.2, Konqueror has become completely unable
to import root certificates with the certificate manager. That makes
secure connections to, e.g. Cacert.org-certified websites _impossible_.
Needless to mention that this is a security problem. The work around
whereby the security warnings are ignored exposes the user to
man-in-the-middle attacks that SSL is supposed to protect from.

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (100, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.29-1-686 (SMP w/2 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages konqueror depends on:
ii  kdebase-bin            4:4.2.2-1         core binaries for the KDE 4 base m
ii  kdebase-data           4:4.2.2-1         shared data files for the KDE 4 ba
ii  kdebase-runtime        4:4.2.2-1         runtime components from the offici
ii  kdelibs5               4:4.2.2-2         core libraries for all KDE 4 appli
ii  libc6                  2.9-9             GNU C Library: Shared libraries
ii  libkonq5               4:4.2.2-1         core libraries for Konqueror
ii  libkonqsidebarplugin4  4:4.2.2-1         Konqueror sidebar plugin library
ii  libqt4-dbus            4.5.1-1           Qt 4 D-Bus module
ii  libqt4-qt3support      4.5.1-1           Qt 3 compatibility library for Qt 
ii  libqt4-xml             4.5.1-1           Qt 4 XML module
ii  libqtcore4             4.5.1-1           Qt 4 core module
ii  libqtgui4              4.5.1-1           Qt 4 GUI module
ii  libstdc++6             4.4.0-3           The GNU Standard C++ Library v3
ii  libx11-6               2:1.2.1-1         X11 client-side library
ii  zlib1g                 1: compression library - runtime

Versions of packages konqueror recommends:
pn  dolphin                       <none>     (no description available)
ii  konqueror-nsplugins           4:4.2.2-1  Netscape plugin support for Konque

Versions of packages konqueror suggests:
ii  konq-plugins                  4:4.2.2-1  plugins for Konqueror, the KDE fil

-- no debconf information

Reply to: