[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#513382: akonadi-server: depends on mysql-server

Package: akonadi-server
Version: 1.1.1-1
Severity: important

The dependency on mysql-server means that at least *two* mysqld
processes will be started: one system-wide and one embedded in Akonadi
(per KDE user!). That is already two more than I want, but definitely
one more than asked for.

akonadi-server should be able to start just the embedded MySQL,
similar to how various packages start embedded Tomcat or Jetty
instances without depending on the system-wide server
package. (Perhaps some refactoring of the MySQL packages is needed?)

Even better, it should use some more light-weight embedded database

-- System Information:
Debian Release: 5.0
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=sv_SE.UTF-8, LC_CTYPE=sv_SE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages akonadi-server depends on:
ii  libakonadiprivate1           1.1.1-1     libraries for the Akonadi PIM stor
ii  libboost-program-options1.34 1.34.1-14   program options library for C++
ii  libc6                        2.7-18      GNU C Library: Shared libraries
ii  libgcc1                      1:4.3.2-1.1 GCC support library
ii  libqt4-dbus                  4.4.3-2     Qt 4 D-Bus module
ii  libqt4-sql-mysql             4.4.3-2     Qt 4 MySQL database driver
ii  libqtcore4                   4.4.3-2     Qt 4 core module
ii  libstdc++6                   4.3.2-1.1   The GNU Standard C++ Library v3
ii  mysql-server                 5.1.30-2    MySQL database server (metapackage
ii  mysql-server-5.1 [mysql-serv 5.1.30-2    MySQL database server binaries

akonadi-server recommends no packages.

akonadi-server suggests no packages.

-- no debconf information

Reply to: