[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Help needed for #377468

On Sat, Dec 20, 2008 at 03:50:21PM +0100, Bastien ROUCARIES wrote:
> Hi!
> I would like to ask for some help for the bug #377468, if possible,
> please. Particularly from a mozilla-plugin wizard.
> The problem is that djvulibre in upstream is not linked against a particular libXt 
> in order to adapt against different libXt version depending of the browser used.
> The question raised by the upsteam is the case of the browser itself already uses libXt, and links to
> a different version of the library than the plugin. 

I think it should link against libXt in any case.

AFAIK libXt properly tracks library version, so linking against it
should actually do the right thing. Of course your plugin might only
use a super stable subset of the symbols in libXt, but even then i
think not linking against the system lib causes troubles.

 - Alexander

Reply to: