[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#482286: qt4-designer: segfault when loading Kde extensions

Package: qt4-designer
Version: 4.4.0-2
Severity: important

*** Please type your report below this line ***
This bug is confirmed on the ppc arch by pos on #debian-kde, not confirmed
on x86 by pusling.

How to reproduce:
0) designer-qt4 seems to work with kdebase-bin-kde3 installed, but this
setup is lacking functionalities.
1) Ensure kdebase-runtime-bin-kde4 is installed in order to use kde 
widgets, -kdebase-bin-kde3 gets removed in the process. 
2) Watch designer-qt4 segfault.

For reference, this is broken either with:
 -Sid versions: 
  kdelibs5: 4:4.0.2-1+b1, 
  kdebase-runtime-bin-kde4: 4:4.0.2-1+b1
 -Experimental versions:
  kdelibs5: 4:4.0.74-1
  kdebase-runtime-bin-kde4: same version

Traces with debugging version of the kdeui library installed:
0) valgrind: http://tuttu.info/~feth/valgrind_designer-qt4.log
1) gdb: http://tuttu.info/~feth/gdb_designer-qt4.log
2) strace: http://tuttu.info/~feth/strace_designer-qt4.log
(sorry, I gave up trying setting a breakpoint in gdb)

Contact submitter with the "jetable" (throwable) address during one
month, or recombine "feth has_an_email_on arezki.net.destroy_this_too"

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: powerpc (ppc)

Kernel: Linux 2.6.24-1-powerpc
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages qt4-designer depends on:
ii  libc6                         2.7-11     GNU C Library: Shared libraries
ii  libgcc1                       1:4.3.0-4  GCC support library
ii  libqt4-designer               4.4.0-2    Qt 4 designer module
ii  libqt4-network                4.4.0-2    Qt 4 network module
ii  libqt4-xml                    4.4.0-2    Qt 4 XML module
ii  libqtcore4                    4.4.0-2    Qt 4 core module
ii  libqtgui4                     4.4.0-2    Qt 4 GUI module
ii  libstdc++6                    4.3.0-4    The GNU Standard C++ Library v3

Versions of packages qt4-designer recommends:
ii  libqt4-dev                    4.4.0-2    Qt 4 development files

-- no debconf information

Reply to: