[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#473658: marked as done (qt4-x11: Provide a virtual libqt4-core package to replace the existing old one)

Your message dated Tue, 08 Apr 2008 13:17:31 +0000
with message-id <E1JjDhb-0001KO-98@ries.debian.org>
and subject line Bug#473658: fixed in qt4-x11 4.4.0~rc1-1
has caused the Debian Bug report #473658,
regarding qt4-x11: Provide a virtual libqt4-core package to replace the existing old one
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

473658: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=473658
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: qt4-x11
Version: 4.4.0~beta1-1
Severity: wishlist

Thank you for packaging the beta of qt4.4. This means I will be able to rebuild the latest kde4 without over filling my little partition with qt4 build tree.

I have a little annoyance with the split of libqt4-core of qt4.3 in three packages libqtcore4 and libqt4-xml and libqt4-network (If there is no mistake from myself). It is no longer possible to use current kde4 packages that are yet built for powerpc.
So is possible to add a virtual package libqt4-core that requires the same subset of modules that it direclty provided in earlier versions.

Thanks in advance for any comments

Best regards

-- System Information:
Debian Release: lenny/sid
  APT prefers experimental
  APT policy: (902, 'experimental'), (900, 'unstable'), (500, 'testing'), (101, 'stable')
Architecture: powerpc (ppc)

Kernel: Linux 2.6.24-1-powerpc
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8) (ignored: LC_ALL set to fr_FR.UTF-8)
Shell: /bin/sh linked to /bin/bash

--- End Message ---
--- Begin Message ---
Source: qt4-x11
Source-Version: 4.4.0~rc1-1

We believe that the bug you reported is fixed in the latest version of
qt4-x11, which is due to be installed in the Debian FTP archive:

  to pool/main/q/qt4-x11/libqt4-assistant_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/libqt4-core_4.4.0~rc1-1_all.deb
  to pool/main/q/qt4-x11/libqt4-dbg_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/libqt4-dbus_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/libqt4-designer_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/libqt4-dev_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/libqt4-gui_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/libqt4-help_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/libqt4-network_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/libqt4-opengl_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/libqt4-qt3support_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/libqt4-script_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/libqt4-sql-ibase_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/libqt4-sql-mysql_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/libqt4-sql-odbc_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/libqt4-sql-psql_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/libqt4-sql-sqlite2_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/libqt4-sql-sqlite_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/libqt4-sql_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/libqt4-svg_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/libqt4-test_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/libqt4-webkit-dbg_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/libqt4-webkit_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/libqt4-xml_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/libqt4-xmlpatterns-dbg_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/libqt4-xmlpatterns_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/libqtcore4_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/qt4-demos_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/qt4-designer_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/qt4-dev-tools_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/qt4-doc_4.4.0~rc1-1_all.deb
  to pool/main/q/qt4-x11/qt4-qtconfig_4.4.0~rc1-1_amd64.deb
  to pool/main/q/qt4-x11/qt4-x11_4.4.0~rc1-1.diff.gz
  to pool/main/q/qt4-x11/qt4-x11_4.4.0~rc1-1.dsc
  to pool/main/q/qt4-x11/qt4-x11_4.4.0~rc1.orig.tar.gz

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 473658@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> (supplier of updated qt4-x11 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Mon, 07 Apr 2008 01:36:54 -0400
Source: qt4-x11
Binary: libqtcore4 libqt4-core libqt4-gui libqt4-network libqt4-opengl libqt4-script libqt4-sql libqt4-sql-ibase libqt4-sql-mysql libqt4-sql-odbc libqt4-sql-psql libqt4-sql-sqlite libqt4-sql-sqlite2 libqt4-svg libqt4-webkit libqt4-xml libqt4-xmlpatterns libqt4-dbus libqt4-qt3support libqt4-designer libqt4-help libqt4-assistant libqt4-test libqt4-dev libqt4-dbg libqt4-webkit-dbg libqt4-xmlpatterns-dbg qt4-designer qt4-dev-tools qt4-qtconfig qt4-demos qt4-doc
Architecture: source all amd64
Version: 4.4.0~rc1-1
Distribution: experimental
Urgency: low
Maintainer: Fathi Boudra <fabo@debian.org>
Changed-By: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
 libqt4-assistant - Qt 4 assistant module
 libqt4-core - transitional package for Qt 4 core non-GUI runtime libraries
 libqt4-dbg - Qt 4 library debugging symbols
 libqt4-dbus - Qt 4 D-Bus module
 libqt4-designer - Qt 4 designer module
 libqt4-dev - Qt 4 development files
 libqt4-gui - Qt 4 GUI module
 libqt4-help - Qt 4 help module
 libqt4-network - Qt 4 network module
 libqt4-opengl - Qt 4 OpenGL module
 libqt4-qt3support - Qt 3 compatibility library for Qt 4
 libqt4-script - Qt 4 script module
 libqt4-sql - Qt 4 SQL module
 libqt4-sql-ibase - Qt 4 InterBase/FireBird database driver
 libqt4-sql-mysql - Qt 4 MySQL database driver
 libqt4-sql-odbc - Qt 4 ODBC database driver
 libqt4-sql-psql - Qt 4 PostgreSQL database driver
 libqt4-sql-sqlite - Qt 4 SQLite 3 database driver
 libqt4-sql-sqlite2 - Qt 4 SQLite 2 database driver
 libqt4-svg - Qt 4 SVG module
 libqt4-test - Qt 4 test module
 libqt4-webkit - Qt 4 WebKit module
 libqt4-webkit-dbg - Qt 4 WebKit library debugging symbols
 libqt4-xml - Qt 4 XML module
 libqt4-xmlpatterns - Qt 4 XML patterns module
 libqt4-xmlpatterns-dbg - Qt 4 XML patterns library debugging symbols
 libqtcore4 - Qt 4 core module
 qt4-demos  - Qt 4 examples and demos
 qt4-designer - Qt 4 Designer
 qt4-dev-tools - Qt 4 development tools
 qt4-doc    - Qt 4 API documentation
 qt4-qtconfig - Qt 4 configuration tool
Closes: 458133 469783 473348 473348 473658
 qt4-x11 (4.4.0~rc1-1) experimental; urgency=low
   * New upstream release. (Closes: #469783)
   +++ Changes by Modestas Vainius:
   * Refresh qt-copy patches:
     * 0167-fix-group-reading.diff - adjust offsets.
     * 0180-window-role.diff - adjust offsets.
     * 0195-compositing-properties.diff - adjust offsets.
     * 0203-qtexthtmlparser-link-color.diff - adjust offsets.
     * 0209-prevent-qt-mixing.diff - adjust offsets.
     * 0214-fix-qgraphicsproxywidget-tab-crash.diff - adjust offsets.
     * 0216-allow-isystem-for-headers.diff - adjust offsets.
   * Remove qt-copy patches:
     * 0172-prefer-xrandr-over-xinerama.diff - merged upstream.
     * 0178-transparency-window-types.diff - merged upstream.
     * 0215-compile-with-Xcursor-linkage.diff - merged upstream.
     * 0217-qurl-isempty-regression.diff - merged upstream.
     * 0218-qassert-macro-fix.diff - merged upstream.
     * fix-qt_bootstrapped-typo.diff  - merged upstream.
   * Add qt-copy patches:
     * 0220-no-x-recursion-in-xerrhandler.diff - adjust offsets.
   * Refresh Debian patches:
     * 02_launch_assistant-qt4.diff - adjust offsets.
     * 05_append_qt4_target.diff - adopt to upstream changes. lrelease and
       lupdate have been moved to tools/linguist/, adjust offsets.
     * 50_kfreebsd_build_fix.diff - adjust offsets.
     * 80_hurd_max_path.diff - adjust offsets.
   * Remove Debian patches:
     * 08_load_ssl.diff - different fix applied upstream.
   * Update *.install files:
     * qt4-dev-tools.install: a few renames of the language files,
       s/assistant-qt3/assistant-qt4/, add usr/bin/xmlpatterns
   * Add libqt4-core transitional package. (Closes: #473658)
   * Add debian/not-installed to document files which are deliberately not
   * Avoid calling ./configure repeatedly during build/install: tie ./configure
     to config.status
   +++ Changes by Fathi Boudra:
   * Re-introduce LD_LIBRARY_PATH workaround to use lrelease.
   * Remove Conflicts against libqt4-core.
   * Reorder libqt4-sql dependencies to have packages available on all
     architectures listed first. (Closes: #473348)
   * Add architectures availability list to libqt4-sql-ibase package.
     (Closes: #473348)
   * Add patch to fix unaligned access on hppa. Thanks to Bernhard R. Link.
     (Closes: #458133)
   * Add patch to replace remaining qdbus by dbus. Fix libqtscriptdbus build.
   * Update configure options:
     * Replace -qdbus by -dbus.
     * Add -svg.
   +++ Changes by Matthew Rosewarne:
   * Rewrite clean rule to remove remaining build cruft.
 50eb9bd1ebe15e0fe23391b95d0deee2 2164 libs optional qt4-x11_4.4.0~rc1-1.dsc
 73a949d0dfb1a35202480b0f2dc5fdfc 108602877 libs optional qt4-x11_4.4.0~rc1.orig.tar.gz
 66966f0c25a057f96db39eb36ecf75ac 83606 libs optional qt4-x11_4.4.0~rc1-1.diff.gz
 a800ee8f0a046f65b7511b21ef3ab122 25318 libs optional libqt4-core_4.4.0~rc1-1_all.deb
 9dfa307bd721145a07feb82144880f4f 74121580 doc optional qt4-doc_4.4.0~rc1-1_all.deb
 65c914cc8d11c9462cc9edc3fcd2c03d 2036176 libs optional libqtcore4_4.4.0~rc1-1_amd64.deb
 1432af719eb0d29a8d508d1e37c03b97 4226614 libs optional libqt4-gui_4.4.0~rc1-1_amd64.deb
 9d44956bf8e0434d5cae0acf33de5caa 445038 libs optional libqt4-network_4.4.0~rc1-1_amd64.deb
 61dc45f03fb5865c04311988631b36be 172320 libs optional libqt4-opengl_4.4.0~rc1-1_amd64.deb
 49b8dd321a8df6c2dd0b30ab2938f329 490104 libs optional libqt4-script_4.4.0~rc1-1_amd64.deb
 7fb1ac2366a8b137726108da09f056a4 125992 libs optional libqt4-sql_4.4.0~rc1-1_amd64.deb
 e0f27c750d3f768018fb7168d38a3a25 67048 libs optional libqt4-sql-ibase_4.4.0~rc1-1_amd64.deb
 b03802c9a2789c9809245dc1b6cdd767 52280 libs optional libqt4-sql-mysql_4.4.0~rc1-1_amd64.deb
 e741820929d974eed74fd8dc9f5a70b3 64908 libs optional libqt4-sql-odbc_4.4.0~rc1-1_amd64.deb
 978c05e9ad5d97adb8f48c7af1278d1a 57530 libs optional libqt4-sql-psql_4.4.0~rc1-1_amd64.deb
 70fd730fec16f91e12931e1cb1e17b39 44086 libs optional libqt4-sql-sqlite_4.4.0~rc1-1_amd64.deb
 d06a3e62f9e2a767b82d5d4a63247f22 40304 libs optional libqt4-sql-sqlite2_4.4.0~rc1-1_amd64.deb
 1c8ae6fdf00e709addf95e715383cd13 176862 libs optional libqt4-svg_4.4.0~rc1-1_amd64.deb
 777975d31c4ee172e7a576c59eafbf1f 3522092 libs optional libqt4-webkit_4.4.0~rc1-1_amd64.deb
 f6e52354788a3b2cdeeaa74ffd45d8e5 132976 libs optional libqt4-xml_4.4.0~rc1-1_amd64.deb
 fb695565aa136477bb8e425e2cf6b619 856944 libs optional libqt4-xmlpatterns_4.4.0~rc1-1_amd64.deb
 70625cda3e5acc2c1b6575c75176abee 230606 libs optional libqt4-dbus_4.4.0~rc1-1_amd64.deb
 c3d59419b10e7870241768bec09db3e1 1350824 libs optional libqt4-qt3support_4.4.0~rc1-1_amd64.deb
 e7bea49d183cf3e7cff3143d55aae076 2001230 libs optional libqt4-designer_4.4.0~rc1-1_amd64.deb
 e337a69babf78f191fe453624323e94b 217888 libs optional libqt4-help_4.4.0~rc1-1_amd64.deb
 b25154e836d0688d4d9727e5158a69d8 36282 libs optional libqt4-assistant_4.4.0~rc1-1_amd64.deb
 fcce23ce688f9a9d2736c42376a93717 55768 libs optional libqt4-test_4.4.0~rc1-1_amd64.deb
 13c0d41c6f4f96291421e549fcc58056 5658716 libdevel optional libqt4-dev_4.4.0~rc1-1_amd64.deb
 b280fb112878391eb5fa60c4f0a1e949 90887778 libs extra libqt4-dbg_4.4.0~rc1-1_amd64.deb
 072c5a92c3658881055ccf6e453cc382 53698024 libs extra libqt4-webkit-dbg_4.4.0~rc1-1_amd64.deb
 679bd01ab2ca3b0305f4afc3c98d7ff4 14106518 libs extra libqt4-xmlpatterns-dbg_4.4.0~rc1-1_amd64.deb
 1dad3f0ba6a80a9f81351883a9e640a4 720608 devel optional qt4-designer_4.4.0~rc1-1_amd64.deb
 97989835baaecd87cb1e99451116f99f 1552896 devel optional qt4-dev-tools_4.4.0~rc1-1_amd64.deb
 efafe61f96a22c9f00c06fea68ebc442 128870 x11 optional qt4-qtconfig_4.4.0~rc1-1_amd64.deb
 88a255e26d2a10bb2bab37a5eca4463b 10260334 x11 optional qt4-demos_4.4.0~rc1-1_amd64.deb

Version: GnuPG v1.4.6 (GNU/Linux)


--- End Message ---

Reply to: