[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#468430: libqt3-mt: qt programs don't support the font substitution rule of fontconfig


yes, I'm pretty sure.

After upgrade the libqt3-mt from version 3.3.7-9 to 3.3.8b-2, I've
already noticed this situation and thought it was the same bug as
#405114. (I've even report it to #405114 [1]).  But after some deeper
diggings, I think these two bugs are different.

First, the situation happend after upgrade to 3.3.8b.  Before the
upgrade, substitution works just fine. And bug #405114 has been
reported fast a year ago.

Second, the situation happens not only because of lacking of some
glyphs in some fonts, but also becasue of someting about locale.

Third, I've tried to set the font substitution rules with qt3-config,
but got the same result, all characters of chinese or korean display
as boxes.

Well, above are the reasons which make me believe, that this bug is
different as #405114. (I've even downloaded the deb package from
ubuntu [2](v3.3.7), and it works fine...)

Qiuye Wang

Reply to: