[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#465759: libode and stormbaan coureur


Le vendredi 15 février 2008, vous avez écrit :
> Matthieu,
> I added an entry to:
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=465464

Ok I read it.

> Could you try to find out whether the problem is in the game, or in libode?

I tried what you suggested but was unable to do it.
I tried to compile ode in order to run the demos but ode configured with 
trimesh support with gimpact does not build on my setup. So I am blocked.

The error is:

make[2]: entrant dans le 
répertoire « /home/mgallien/src/ode-0.9.dfsg/powerpc-linux/ode/src »
g++ -DHAVE_CONFIG_H -I. -I../../include/ode -I../../../ode/src  -O2 -fPIC -g -I../../../include -I../../include -I/home/mgallien/src/ode-0.9.dfsg/GIMPACT/include -DdTRIMESH_ENABLED -DdTRIMESH_GIMPACT  -g -I -L -MT 
libode_a-obstack.o -MD -MP -MF .deps/libode_a-obstack.Tpo -c -o 
libode_a-obstack.o `test -f 'obstack.cpp' || 
echo '../../../ode/src/'`obstack.cpp
Dans le fichier inclus à partir de ../../../ode/src/obstack.cpp:23:
../../../include/ode/common.h:114:2: erreur: #error You can only #define 

So I had to build it with dpkg and magically everything is working.
To be honest I do not want to look at the exact reason of that mess.
Anyway, I tried running some demos and the results are mitigated:
./demo_basket and ./demo_buggy run well

./demo_collision fails with this error msg:
testing batch 1 (1000 reps)...

ODE INTERNAL ERROR: bad n wrt p2
zsh: abort      ./demo_collision

Maybe the bug has to reassigned to ode.

You can decide what you think is the best solution.
I can not found more time before two weeks due to other constraints in order 
to run more demos.

>   bram

GALLIEN Matthieu

Reply to: