[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#465029: [Pkg-virtualbox-devel] Bug#465029: Bug#465029: virtualbox-ose: undefined symbol: stat64

On Sun, Feb 10, 2008 at 12:04:45PM +0100, Patrick Winnertz wrote:
> Am Sonntag, 10. Februar 2008 11:38:48 schrieb Michael Hanke:
> > I checked that already and it does not seem to be the problem. I have
> > this:
> >
> > michael@gandalf:/lib/modules/2.6.24-1-686$ uname -a
> > Linux gandalf 2.6.24-1-686 #1 SMP Wed Feb 6 15:20:27 UTC 2008 i686
> > GNU/Linux
> >
> > michael@gandalf:/lib/modules/2.6.24-1-686$ find . -name vboxdrv.ko
> > ./extra/virtualbox-ose/vboxdrv.ko
> mh.. okay.
> What about building the module on your own?
> For this please install virtualbox-ose-source and then
> # m-a -t auto-install virtualbox-ose-source
> This module should be located under:
>      /lib/modules/$KVERS/misc/vboxdrv.ko
> The module above is from linux-modules-extra and is prebuilded.
> If the module is builded please modprobe/or insmod it and make sure that 
> this and not the other one is loaded. 
> (The easiest thing would be: 
> rmmod vboxdrv; 
> insmod /lib/modules/$KVERS/misc/vboxdrv.ko;
> )
> Hopefully this helps to get rid of the error.
Sorry, I forgot to mention that I already tried this as well. I redid
everything with the explicite commands that you suggested and the
problem is still there (same error).

Additionally, I also think that it cannot be related to the module as the
VirtualBox GUI should even start without any module present (neither loaded
nor even installed).

I also gave the binary-only innotek package a tried and it works (same
kernel, ...). So I guess it cannot be a general problem.



GPG key:  1024D/3144BE0F Michael Hanke
ICQ: 48230050

Reply to: