[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#462338: marked as done (kdelibs5-dev: not installable on GNU/kFreeBSD)

Your message dated Mon, 04 Feb 2008 11:17:08 +0000
with message-id <E1JLzK0-0005Kl-Sb@ries.debian.org>
and subject line Bug#462338: fixed in kde4libs 4:4.0.1-1
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: kdelibs5-dev
Version: 4:4.0.0-2
Severity: important
Tags: patch

kde4libs builds find on GNU/kFreeBSD (thanks :-), but kdelibs5-dev is
not installable as it depends on Linux specific package. The small
patch below fixes the problem.

Could you please apply it in the next upload? Thanks in advance.

--- kde4libs-4.0.0/debian/control	2008-01-24 00:46:38.000000000 +0000
+++ kde4libs-4.0.0/debian/control	2008-01-24 00:46:40.000000000 +0000
@@ -39,7 +39,7 @@
 Section: libdevel
 Architecture: any
 Depends: ${shlibs:Depends}, kdelibs5 (= ${binary:Version}), shared-mime-info,
- libasound2-dev, libcupsys2-dev, libdbus-1-dev, libkeyutils-dev, libqt4-dev,
+ libasound2-dev [linux-any], libcupsys2-dev, libdbus-1-dev, libkeyutils-dev [linux-any], libqt4-dev,
  libsoprano-dev (>= 1.99~rc2-1), libstreamanalyzer-dev (>= 0.5.7),
  libxml2-dev, libxml2-utils, libxslt1-dev, libxtst-dev, libungif4-dev,
  libavahi-common-dev, libaspell-dev, libbz2-dev, libenchant-dev, libfam-dev,

-- System Information:
Debian Release: lenny/sid
Architecture: kfreebsd-i386 (i686)

Kernel: kFreeBSD 6.2-1-686
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

--- End Message ---
--- Begin Message ---
Source: kde4libs
Source-Version: 4:4.0.1-1

We believe that the bug you reported is fixed in the latest version of
kde4libs, which is due to be installed in the Debian FTP archive:

  to pool/main/k/kde4libs/kde4libs_4.0.1-1.diff.gz
  to pool/main/k/kde4libs/kde4libs_4.0.1-1.dsc
  to pool/main/k/kde4libs/kde4libs_4.0.1.orig.tar.gz
  to pool/main/k/kde4libs/kdelibs-bin_4.0.1-1_amd64.deb
  to pool/main/k/kde4libs/kdelibs5-data_4.0.1-1_all.deb
  to pool/main/k/kde4libs/kdelibs5-dbg_4.0.1-1_amd64.deb
  to pool/main/k/kde4libs/kdelibs5-dev_4.0.1-1_amd64.deb
  to pool/main/k/kde4libs/kdelibs5-doc_4.0.1-1_all.deb
  to pool/main/k/kde4libs/kdelibs5_4.0.1-1_amd64.deb
  to pool/main/k/kde4libs/libphonon-dev_4.0.1-1_amd64.deb
  to pool/main/k/kde4libs/libphonon4_4.0.1-1_amd64.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 462338@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> (supplier of updated kde4libs package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Mon, 04 Feb 2008 09:59:44 +0100
Source: kde4libs
Binary: kdelibs5 kdelibs5-data kdelibs5-dev kdelibs5-doc kdelibs-bin kdelibs5-dbg libphonon-dev libphonon4
Architecture: source all amd64
Version: 4:4.0.1-1
Distribution: unstable
Urgency: low
Maintainer: Fathi Boudra <fabo@debian.org>
Changed-By: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
 kdelibs-bin - executables for all KDE 4 core applications
 kdelibs5   - core libraries for all KDE 4 applications
 kdelibs5-data - core shared data for all KDE 4 applications
 kdelibs5-dbg - debugging symbols for the KDE 4 libraries module
 kdelibs5-dev - development files for the KDE 4 core libraries
 kdelibs5-doc - developer documentation for the KDE 4 core libraries
 libphonon-dev - development files for the Phonon multimedia framework
 libphonon4 - Phonon multimedia framework for Qt 4
Closes: 462338
 kde4libs (4:4.0.1-1) unstable; urgency=low
   * New upstream release.
   +++ Changes by Matthew Rosewarne:
   * Make dependencies binNMU-friendly.
   * Bump Soprano minimum version to 2.0.0.
   * Remove redundant Depends: shared-mime-info from kdelibs5-dev.
   * Add Suggests: kdelibs5-doc to kdelibs5-dev.
   +++ Changes by Armin Berres:
   * Update 10_kdehome_kde4 patch. Set kde home directory to ~/.kde4
     where ~/.kde was used. Thanks to Jonathan Riddell and Suse people.
   * Update installed files.
   * Drop no more needed patch 16_arm_fixes.diff.
   +++ Changes by Fathi Boudra:
   * Make kdelibs5-dev installable on GNU/kFreeBSD. Thanks to Aurelien Jarno.
     (Closes: #462338)
   * Add dbus-x11 dependency to kdelibs5. Thanks to Chris Desjardins.
   * Add Vcs-Browser and Vcs-Svn fields.
   * Cherry pick from branches/KDE/4.0:
     + 02_re-register_global_shortcuts_r769363:
       Re-register global shortcuts if kded4 is restarted.
   +++ Changes by Adeodato Simó:
   * Cherry pick from /branches/KDE/4.0:
     + 01_make_stackingOrder_work_r769072: fix KWindowSystem::stackingOrder() to
       actually return a non-empty list with the list of windows.
   +++ Changes by Ana Beatriz Guerrero Lopez:
   * Update to debhelper 6.
   * Add versioned b-d on cdbs (>= 0.4.51) to get debhelper 6 support and fixed
     cmake.mk class.
 98f072b190d8038ba550c643c50b4c9c 1697 libs optional kde4libs_4.0.1-1.dsc
 74891b351202b6192054ffcdf52a251c 11033033 libs optional kde4libs_4.0.1.orig.tar.gz
 9ba858f53da25deee348fc80884446e5 71686 libs optional kde4libs_4.0.1-1.diff.gz
 a923b45fc7e6398f045ef4b4d0e4894c 3102166 libs optional kdelibs5-data_4.0.1-1_all.deb
 17bbab957632ced57db601e47656e0f3 60292 doc optional kdelibs5-doc_4.0.1-1_all.deb
 00634d917d31979abec356fda8c68e5a 9524642 libs optional kdelibs5_4.0.1-1_amd64.deb
 7b11174a4fd8500752da8b3d295c1a8c 1408866 libdevel optional kdelibs5-dev_4.0.1-1_amd64.deb
 3171f61f5a1fd7beeaf14310eff0f07c 445036 libs optional kdelibs-bin_4.0.1-1_amd64.deb
 b21bf0af9de98ad0c2a00735ab95735b 60729112 libdevel extra kdelibs5-dbg_4.0.1-1_amd64.deb
 dc6b8e4dc9e45f18d6cbc0d8f7d089f4 102766 libdevel optional libphonon-dev_4.0.1-1_amd64.deb
 1767d95f5c66c45cf74c5c1cb1876445 170458 libs optional libphonon4_4.0.1-1_amd64.deb

Version: GnuPG v1.4.6 (GNU/Linux)


--- End Message ---

Reply to: