[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#462884: kate: it is impossible to have two versions of /usr/lib/libkateinterfaces.so installed

Package: kate
Version: 4:3.98.0~svn755919-1
Severity: important


package kate contains a shared library /usr/lib/libkateinterfaces.so and some applications (kscope) link to it. However, these applications break when kate from kde4 is installed, because this version has different soname. I think it would be nice to have this library in a library package, according to policy 8.1.

    Jiri Palecek

-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux (PREEMPT)
Locale: LANG=cs_CZ, LC_CTYPE=cs_CZ (charmap=ISO-8859-2) (ignored: LC_ALL set to cs_CZ)
Shell: /bin/sh linked to /bin/dash

Versions of packages kate depends on:
ii  kde-icons-oxygen          4:4.0.0-1      Oxygen icon theme for KDE 4
ii kdebase-runtime 4:4.0.0-1 runtime components from the offici ii kdebase-runtime-data 4:4.0.0-1 shared data files for the KDE base ii kdelibs5 4:4.0.0-1 core libraries for all KDE 4 appli ii libc6 2.7-3 GNU C Library: Shared libraries ii libqt4-core 4.3.3-1 Qt 4 core non-GUI functionality ru ii libqt4-gui 4.3.3-1 Qt 4 core GUI functionality runtim ii libqt4-qt3support 4.3.3-1 Qt 3 compatibility library for Qt ii libstdc++6 4.3-20071020-1 The GNU Standard C++ Library v3

Versions of packages kate recommends:
pn  kregexpeditor                 <none>     (no description available)

-- no debconf information

Using Opera's revolutionary e-mail client: http://www.opera.com/mail/

Reply to: