[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#457436: XDMCP stopped working

Package: kdm
Version: 4:3.5.8.dfsg.1-2
Severity: normal

--- Please enter the report below this line. ---
I am running a system with an attached thin-client. Some weeks ago all logins 
at the thin-client failed.
First I thought it is because I did not update the thin-client for ages (it 
happend once before that terminals running older versions of X 
became "incompatible" with the server, e.g. keyboard selection stopped 
working, ...). Now I updated the thin-client system and noticed that logins 
still fail.
I even tested locally with Xephyr and noticed that XDMCP really stopped 
working. You can reproduce the bug as follows:
- enable XDMCP in /etc/kde3/kdm/kdmrc
- allow a login window for any host in /etc/kde3/kdm/Xaccess
- restart kdm and log in
- open a terminal window and call "Xephyr :1 -ac -query localhost"
- try logging in

On a Debian stable system this works instantly. On a Debian testing system I 
see the login window and can type in the user name and password. When 
pressing the login button the screen just goes blank for a moment and the 
login window reappears.

PS: I tested the same procedure with GDM and there I even do not get the login 
window anymore. So maybe the bug is somewhere deeper in the system than just 

--- System information. ---
Architecture: i386
Kernel:       Linux 2.6.22-3-686

Debian Release: lenny/sid
  500 testing         security.debian.org 
  500 testing         ftp.ch.debian.org 

--- Package information. ---
Depends                       (Version) | Installed
kdelibs4c2a              (>= 4:3.5.8-1) | 4:3.5.8.dfsg.1-4
libc6                      (>= 2.6.1-1) | 2.7-4
libdbus-1-3                  (>= 1.1.1) | 1.1.1-3
libgcc1                    (>= 1:4.2.1) | 1:4.2.2-4
libpam0g                  (>= |
libqt3-mt                  (>= 3:3.3.7) | 3:3.3.7-9
libstdc++6                   (>= 4.2.1) | 4.2.2-4
libx11-6                                | 2:1.0.3-7
libxau6                                 | 1:1.0.3-2
libxdmcp6                               | 1:1.0.2-2
libxtst6                                | 2:1.0.3-1
kdebase-bin        (= 4:3.5.8.dfsg.1-2) | 4:3.5.8.dfsg.1-2
kdebase-data        (>> 4:3.5.8.dfsg.1) | 4:3.5.8.dfsg.1-2
kdebase-data        (<< 4:3.5.8.dfsg.2) | 4:3.5.8.dfsg.1-2
debconf                     (>= 1.2.9)  | 1.5.17
 OR debconf-2.0                         | 
libpam-runtime             (>= 0.76-14) |
xbase-clients                           | 1:7.2.ds2-2

Reply to: