[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#449130: marked as done (soprano: not binNMU safe)

Your message dated Wed, 14 Nov 2007 13:17:02 +0000
with message-id <E1IsI74-00042x-N9@ries.debian.org>
and subject line Bug#449130: fixed in soprano 1.97.1~beta4-1
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: soprano
Version: 1.95.0~beta2-1
Severity: normal
Tags: patch


You've used ${binary:Version} instead of ${source:Version} in libsoprano-dev
depends line. Please use fix that so the package will have the right dependencies in case of binNMU. A patch is attached.


-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.22-3-k7 (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash
--- /tmp/control	2007-11-03 14:03:06.000000000 +0200
+++ debian/control	2007-11-03 14:03:45.000000000 +0200
@@ -24,7 +24,7 @@
 Package: libsoprano-dev
 Architecture: all
-Depends: ${shlibs:Depends}, ${misc:Depends}, libsoprano4 (= ${binary:Version})
+Depends: ${shlibs:Depends}, ${misc:Depends}, libsoprano4 (= ${source:Version})
 Description: Development files for soprano, a Qt4 interface for RDF storage
  Soprano (formally known as QRDF) is a library which provides a nice Qt4
  interface to RDF storage solutions. It has a modular structure which allows 

--- End Message ---
--- Begin Message ---
Source: soprano
Source-Version: 1.97.1~beta4-1

We believe that the bug you reported is fixed in the latest version of
soprano, which is due to be installed in the Debian FTP archive:

  to pool/main/s/soprano/libsoprano-dev_1.97.1~beta4-1_i386.deb
  to pool/main/s/soprano/libsoprano4_1.97.1~beta4-1_i386.deb
  to pool/main/s/soprano/soprano_1.97.1~beta4-1.diff.gz
  to pool/main/s/soprano/soprano_1.97.1~beta4-1.dsc
  to pool/main/s/soprano/soprano_1.97.1~beta4.orig.tar.gz

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 449130@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> (supplier of updated soprano package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Wed, 14 Nov 2007 14:04:18 +0100
Source: soprano
Binary: libsoprano4 libsoprano-dev
Architecture: source i386
Version: 1.97.1~beta4-1
Distribution: unstable
Urgency: low
Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Changed-By: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
 libsoprano-dev - Development files for soprano, a Qt4 interface for RDF storage
 libsoprano4 - Qt4 interface to RDF storage
Closes: 447620 449130
 soprano (1.97.1~beta4-1) unstable; urgency=low
   * New upstream release.
   +++ Changes by Armin Berres:
   * Make soprano binNMUable (Closes: #449130).
   * Add watch file.
   +++ Changes by Fathi Boudra:
   * Add myself in uploaders.
   * libsoprano-dev should be in section libdevel (Closes: 447620).
   * Add Homepage in long description.
   * Update libsoprano-dev include files.
   * Update patch.
   ++ changes by Ana Beatriz Guerrero Lopez:
   * Move Homepage into control field.
   * Repackage to remove nonfree stuff and upload.
 865507faf033a2fc776b035af6708c72 936 libs extra soprano_1.97.1~beta4-1.dsc
 20625de9924361a16d5fee91735736b3 414781 libs extra soprano_1.97.1~beta4.orig.tar.gz
 9467884a0c004be900d75fd14614d58f 7629 libs extra soprano_1.97.1~beta4-1.diff.gz
 39ab63a0cce500426008ea4ce74851f4 495702 libs extra libsoprano4_1.97.1~beta4-1_i386.deb
 5455e373e5caf7b0054f91b009b0c127 48878 libdevel extra libsoprano-dev_1.97.1~beta4-1_i386.deb

Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Signed by Ana Guerrero


--- End Message ---

Reply to: