[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#354382: marked as done (kmail (crypto-module openpgp) cannot decrypt messages)



Your message dated Tue, 13 Feb 2007 22:40:49 +0100
with message-id <200702132240.49833.debian@pusling.com>
and subject line found workaround
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: kmail
Version: 4:3.5.1-1
Severity: normal


kmail fails in decrypting my test messages I sent to myself with kmail:

  "Verschlüsselte Nachricht (keine Entschlüsselung möglich)
  Grund: Das Krypto-Modul "openpgp" kann die Daten nicht entschlüsseln.
  Fehler: Falsche Passphrase"

  (roughly translates to "encrpyted message (no encryption possible)
  Reason: The crypto module "openpgp" can not decrypt the data.
  Error: Wrong Passphrase"

I haven't been prompted for a passphrase. In Preferences > Security > Crypto-Modules,
the GpgME-Backends OpenPGP (gpg) and S/MIME (gpgsm) are enabled.

$ dpkg -l|grep gpg
ii  gpgsm                           1.9.20-1                    GNU privacy guard - S/MIME version
ii  kgpg                            3.5.1-2                     GnuPG frontend for KDE
ii  libgpg-error0                   1.1-4                       library for common error values and messages in GnuPG components
ii  libgpgme11                      1.1.0-1                     GPGME - GnuPG Made Easy
$ dpkg -l|grep gnupg
ii  gnupg                           1.4.2-2                     GNU privacy guard - a free PGP replacement
ii  gnupg-agent                     1.9.20-1                    GNU privacy guard - password agent
ii  gnupg2                          1.9.20-1                    GNU privacy guard - a free PGP replacement



-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.15-1-k7
Locale: LANG=de_DE, LC_CTYPE=de_DE (charmap=ISO-8859-1)

Versions of packages kmail depends on:
ii  kdebase-kio-plugins       4:3.5.1-1      core I/O slaves for KDE
ii  kdelibs4c2a               4:3.5.1-2      core libraries for all KDE applica
ii  kdepim-kio-plugins        4:3.5.1-1      KDE pim I/O Slaves
ii  libart-2.0-2              2.3.17-1       Library of functions for 2D graphi
ii  libaudio2                 1.7-4          The Network Audio System (NAS). (s
ii  libc6                     2.3.6-2        GNU C Library: Shared libraries an
ii  libfontconfig1            2.3.2-1.1      generic font configuration library
ii  libfreetype6              2.1.10-1       FreeType 2 font engine, shared lib
ii  libgcc1                   1:4.0.2-9      GCC support library
ii  libice6                   6.9.0.dfsg.1-4 Inter-Client Exchange library
ii  libidn11                  0.5.18-2       GNU libidn library, implementation
ii  libjpeg62                 6b-11          The Independent JPEG Group's JPEG 
ii  libkcal2b                 4:3.5.1-1      KDE calendaring library
ii  libkdepim1a               4:3.5.1-1      KDE PIM library
ii  libkleopatra1             4:3.5.1-1      KDE GnuPG interface libraries
ii  libkmime2                 4:3.5.1-1      KDE MIME interface library
ii  libkpimidentities1        4:3.5.1-1      KDE PIM user identity information 
ii  libksieve0                4:3.5.1-1      KDE mail/news message filtering li
ii  libmimelib1c2a            4:3.5.1-1      KDE mime library
ii  libpng12-0                1.2.8rel-5     PNG library - runtime
ii  libqt3-mt                 3:3.3.5-4      Qt GUI Library (Threaded runtime v
ii  libsm6                    6.9.0.dfsg.1-4 X Window System Session Management
ii  libstdc++6                4.0.2-9        The GNU Standard C++ Library v3
ii  libx11-6                  6.9.0.dfsg.1-4 X Window System protocol client li
ii  libxcursor1               1.1.3-1        X cursor management library
ii  libxext6                  6.9.0.dfsg.1-4 X Window System miscellaneous exte
ii  libxft2                   2.1.8.2-3      FreeType-based font drawing librar
ii  libxi6                    6.9.0.dfsg.1-4 X Window System Input extension li
ii  libxinerama1              6.9.0.dfsg.1-4 X Window System multi-head display
ii  libxrandr2                6.9.0.dfsg.1-4 X Window System Resize, Rotate and
ii  libxrender1               1:0.9.0.2-1    X Rendering Extension client libra
ii  libxt6                    6.9.0.dfsg.1-4 X Toolkit Intrinsics
ii  perl                      5.8.7-10       Larry Wall's Practical Extraction 
ii  zlib1g                    1:1.2.3-9      compression library - runtime

Versions of packages kmail recommends:
ii  kdebase-kio-plugins           4:3.5.1-1  core I/O slaves for KDE
ii  kdepim-kio-plugins            4:3.5.1-1  KDE pim I/O Slaves
pn  procmail                      <none>     (no description available)

-- no debconf information


--- End Message ---
--- Begin Message ---
On Sunday 12 November 2006, Sune Vuorela wrote:

> I think I am closing this bug soon

Closing.

/Sune
-- 
Do you know how to upload the window?

From Netscape or from the options menu inside Windows NT you either never have 
to disconnect the gadget, or never have to install on a 9-bit fan of a 
parallel SMTP URL.

Attachment: pgphMAL151h5n.pgp
Description: PGP signature


--- End Message ---

Reply to: