[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#404157: FTBFS: detect-autoconf.pl can't find autom4te, causes "./admin/cvs.sh: line 33: --version: command not found"



On Friday 22 December 2006 02:33, Sune Vuorela wrote:
> How is your perl?
> Do you have autoconf2.13 installed?

$ acp autoconf
autoconf:
  Installed: 2.61-3
  Candidate: 2.61-3
  Version table:
 *** 2.61-3 0
        800 http://ftp.us.debian.org unstable/main Packages
        100 /var/lib/dpkg/status
     2.61-1 0
        900 http://ftp.us.debian.org testing/main Packages

$ acp autoconf2.13
autoconf2.13:
  Installed: 2.13-58
  Candidate: 2.13-58
  Version table:
 *** 2.13-58 0
        900 http://ftp.us.debian.org testing/main Packages
        800 http://ftp.us.debian.org unstable/main Packages
        100 /var/lib/dpkg/status

$ acp perl
perl:
  Installed: 5.8.8-7
  Candidate: 5.8.8-7
  Version table:
 *** 5.8.8-7 0
        800 http://ftp.us.debian.org unstable/main Packages
        100 /var/lib/dpkg/status
     5.8.8-6.1 0
        900 http://ftp.us.debian.org testing/main Packages

As far as I know, Perl is fine on my system.  I'm not aware of any other 
problems with it.

I have another problem that I suppose could be related.  I commented out that 
part of detect-autoconf.pl, and now in the build process I get this error:

make[1]: Entering directory 
`/home/first/Temp/src/akregator/kdepim-3.5.5.dfsg.1'
autoconf (GNU Autoconf) 2.61
*** automake (GNU automake) 1.9.6 found.
*** Creating acinclude.m4
*** Creating configure.files
*** Creating config.h template
/usr/bin/autoconf2.50: line 582: exec: : not found
automake: /usr/bin/autoconf2.50 failed with exit status: 127
make[1]: *** [dist] Error 1
make[1]: Leaving directory 
`/home/first/Temp/src/akregator/kdepim-3.5.5.dfsg.1'
make: *** [debian/stamp-cvs-make] Error 2
E: Building failed

I don't have a clue what could be causing this.  Thanks for your help.

Attachment: pgpNH8sOct4OC.pgp
Description: PGP signature


Reply to: