[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#394836: libqt4-dev: qmake : cannot find -lmysqlclient_r

Package: libqt4-dev
Version: 4.2.0-2
Severity: normal

qmake with QT += sql adds the following dependency: -lmysqlclient_r
This only works if libmysqlclient15-dev is installed ...

If I recall correctly, prior to version 4.2 of this package, qmake
didn't generate a Makefile with -lmysqlclient_r and -lsqlite and -lpq.

Why has this changed in 4.2 ?

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-1-686
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Versions of packages libqt4-dev depends on:
ii  libaudio-dev                 1.8-2       The Network Audio System (NAS). (d
ii  libfreetype6-dev             2.2.1-5     FreeType 2 font engine, developmen
ii  libgl1-mesa-dev [libgl-dev]  6.5.1-0.2   A free implementation of the OpenG
ii  libglib2.0-dev               2.12.4-1    Development files for the GLib lib
ii  libglu1-mesa-dev [libglu-dev 6.5.1-0.2   The OpenGL utility library -- deve
ii  libice-dev                   1:1.0.1-2   X11 Inter-Client Exchange library 
ii  libjpeg62-dev                6b-13       Development files for the IJG JPEG
ii  libmng-dev                   1.0.9-1     M-N-G library (Development headers
ii  libpng12-dev [libpng12-0-dev 1.2.8rel-7  PNG library - development
ii  libpq-dev                    8.1.5-1     header files for libpq4 (PostgreSQ
ii  libqt4-core                  4.2.0-2     Qt 4 core non-GUI functionality ru
ii  libqt4-gui                   4.2.0-2     Qt 4 core GUI functionality runtim
ii  libqt4-qt3support            4.2.0-2     Qt 3 compatibility library for Qt 
ii  libqt4-sql                   4.2.0-2     Qt 4 SQL database module
ii  libsm-dev                    1:1.0.1-3   X11 Inter-Client Exchange library 
ii  libsqlite0-dev               2.8.17-1    SQLite development files
ii  libx11-dev                   2:1.0.3-2   X11 client-side library (developme
ii  libxcursor-dev               1.1.7-4     X cursor management library (devel
ii  libxext-dev                  1:1.0.1-2   X11 miscellaneous extensions libra
ii  libxft-dev            FreeType-based font drawing librar
ii  libxi-dev                    1:1.0.1-3   X11 Input extension library (devel
ii  libxinerama-dev              1:1.0.1-4.1 X11 Xinerama extension library (de
ii  libxmu-dev                   1:1.0.2-2   X11 miscellaneous utility library 
ii  libxrandr-dev                2: X11 RandR extension library (devel
ii  libxrender-dev               1:0.9.1-3   X Rendering Extension client libra
ii  libxt-dev                    1:1.0.2-2   X11 toolkit intrinsics library (de
ii  x11proto-core-dev            7.0.7-2     X11 core wire protocol and auxilia
ii  zlib1g-dev                   1:1.2.3-13  compression library - development

Versions of packages libqt4-dev recommends:
ii  qt4-dev-tools                 4.2.0-2    Qt 4 development tools

-- no debconf information

Reply to: