[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#393041: kdesu no longer accepts correct password

Package: kdelibs
Version: 4:3.5.5a-1


Immediately prior to upgrading kdelibs-related packages (kdelibs,  
kdelibs-data, kdelibs4-dev, kdelibs4-doc, kdelibs4c2a) from version 
4:3.5.4-3, I was able to successfully use the kdesu dialog to launch a 
konqueror window as root.

I then upgraded to version 4:3.5.5a-1 of the above packages. As near as I 
could tell, everything else worked fine except I could no longer use the 
kdesu dialog; the dialog would appear as normal, but it rejected the root 
password and displayed an error indicating "incorrect password." Just to make 
sure I was entering the correct root password, I opened a console window and 
successfully su 'ed to root.

I deleted all contents of /tmp and rebooted, tried again, and received the 
same error. I then downloaded and reinstalled the 4:3.5.5a-1 version of the 
packages, but I still got the error message.

Finally, I downloaded and reinstalled the previous version of these packages 
(i.e., version 4:3.5.4-3), and I was able to use kdesu again.

The bottom line is that version 4:3.5.5a-1 breaks kdesu.


I am using Debian GNU/Linux (etch) 2.6.17-2-686 #1 SMP Wed Sep 13 16:34:10 UTC 
2006 i686; For KDE, I am running 3.5.4

- Thomas Long

Using Debian GNU/Linux

Reply to: