[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#386460: Building a package with libqt4-dev on arm times out



Package: libqt4-dev
Version: 4.1.4-1.1
Severity: normal

Hi,

my package qbrew FTBFS on arm, it links against libqt4. The reason for the 
build failure is a time out while running this command:
/usr/bin/uic-qt4 src/calcconfig.ui -o build/ui_calcconfig.h

I've talked to the arm porters on IRC, and they suggested that it might be 
related to libqt4 not being compiled with -DQT_QLOCALE_USES_FCVT, which was 
a needed fix for libqt3 on arm. From the changelog:

qt-x11-free (3:3.3.3-4.1) unstable; urgency=high 
   * On arm-linux, configure using -DQT_QLOCALE_USES_FCVT. Seems to be a
     known issue, mentioned in the 3.3.2 release notes, but nowhere in
     the 3.3.3 sources. Great! Thanks to Paul Brook and Jan Niehusmann for
     the investigations. Closes: #270202.

The build log of my package qbrew can be found here:
<http://buildd.debian.org/fetch.php?&pkg=qbrew&ver=0.3.9-2&arch=arm&stamp=1157506321&file=log&as=raw>

Are you aware of this problem? Is anyone trying to compile qt4 
with -DQT_QLOCALE_USES_FCVT on arm, to see if the problem can be solved?

Regards,
Tobias

-- 
Tobias Toedter   | Early to bed and early to rise and you'll
Hamburg, Germany | be groggy when everyone else is wide awake.

Attachment: pgp75ofjSDIcM.pgp
Description: PGP signature


Reply to: