[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#374508: konqueror: Confusing error if HTTPS encryption method can't be agreed

Package: konqueror
Version: 4:3.5.3-2
Severity: normal

If, when accessing an HTTPS server,
all the encryption methods that the webserver
is willing to support are disabled in Konqueror's config,
then the default "Can't connect" error message is displayed.

Since this error does not indicate that HTTPS failed,
it is not clear to the user that (s)he should review
the security settings in Settings/Configure Konqueror/Crypto.

Konqueror should give a different error if HTTPS encryption negotation
fails, inviting the user to review the settings, and perhaps listing the
methods the webserver is willing to use.

Colin S. Miller

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.15-1-486
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)

Versions of packages konqueror depends on:
ii  kcontrol                    4:3.5.3-2    control center for KDE
ii  kdebase-kio-plugins         4:3.5.3-2    core I/O slaves for KDE
ii  kdelibs4c2a                 4:3.5.3-1    core libraries and binaries for al
ii  kdesktop                    4:3.5.3-2    miscellaneous binaries and files f
ii  kfind                       4:3.5.3-2    file-find utility for KDE
ii  libacl1                     2.2.37-1     Access control list shared library
ii  libart-2.0-2                2.3.17-1     Library of functions for 2D graphi
ii  libattr1                    2.4.32-1     Extended attribute shared library
ii  libaudio2                   1.7-9        The Network Audio System (NAS). (s
ii  libc6                       2.3.6-13     GNU C Library: Shared libraries
ii  libfontconfig1              2.3.2-5.1    generic font configuration library
ii  libfreetype6                2.2.1-2      FreeType 2 font engine, shared lib
ii  libgamin0 [libfam0]         0.1.7-3      Client library for the gamin file 
ii  libgcc1                     1:4.1.0-4    GCC support library
ii  libice6                     1:1.0.0-3    X11 Inter-Client Exchange library
ii  libidn11                    0.5.18-2     GNU libidn library, implementation
ii  libjpeg62                   6b-13        The Independent JPEG Group's JPEG 
ii  libkonq4                    4:3.5.3-2    core libraries for Konqueror
ii  libpng12-0                  1.2.8rel-5.1 PNG library - runtime
ii  libqt3-mt                   3:3.3.6-2    Qt GUI Library (Threaded runtime v
ii  libsm6                      1:1.0.0-4    X11 Session Management library
ii  libstdc++6                  4.1.0-4      The GNU Standard C++ Library v3
ii  libx11-6                    2:1.0.0-6    X11 client-side library
ii  libxcursor1           X cursor management library
ii  libxext6                    1:1.0.0-4    X11 miscellaneous extension librar
ii  libxft2               FreeType-based font drawing librar
ii  libxi6                      1:1.0.0-5    X11 Input extension library
ii  libxinerama1                1:1.0.1-4    X11 Xinerama extension library
ii  libxrandr2                  2:  X11 RandR extension library
ii  libxrender1                 1:  X Rendering Extension client libra
ii  libxt6                      1:1.0.0-5    X11 toolkit intrinsics library
ii  zlib1g                      1:1.2.3-11   compression library - runtime

konqueror recommends no packages.

-- no debconf information

Reply to: