[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#360802: marked as done (libqt4-dev: libQt3Support.la erroneously links several sql libraries (app need none))

Your message dated Sat, 03 Jun 2006 20:03:36 -0700
with message-id <E1Fmits-0001zB-0y@spohr.debian.org>
and subject line Bug#360802: fixed in qt4-x11 4.1.3-1
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: libqt4-dev
Version: 4.1.1-1
Severity: normal

I tried compiling the development version of lyx, which uses qt4.
It compiled fine, but I was surprised having to install
3 new sql libraries in order to link. Lyx doesn't use any sql at all.
The problem exists only on debian, not other distributions.

The fault was found in  /usr/lib/libQt3Support.la, which
wants to link all sorts of sql libraries.

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (900, 'testing'), (800, 'unstable')
Architecture: amd64 (x86_64)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.16-rc6-mm2
Locale: LANG=nb_NO.UTF-8, LC_CTYPE=nb_NO.UTF-8 (charmap=UTF-8)

Versions of packages libqt4-dev depends on:
ii  libaudio-dev              1.7-5          The Network Audio System (NAS). (d
ii  libfreetype6-dev          2.1.10-1       FreeType 2 font engine, developmen
ii  libglu1-xorg-dev [libglu- 6.9.0.dfsg.1-4 Mesa OpenGL utility library develo
ii  libice-dev                6.9.0.dfsg.1-4 Inter-Client Exchange library deve
ii  libjpeg62-dev             6b-12          Development files for the IJG JPEG
ii  libmng-dev                1.0.8-1        M-N-G library (Development headers
ii  libpng12-dev [libpng12-0- 1.2.8rel-5     PNG library - development
ii  libqt4-core               4.1.1-1        Qt 4 core non-GUI functionality ru
ii  libqt4-gui                4.1.1-1        Qt 4 core GUI functionality runtim
ii  libqt4-qt3support         4.1.1-1        Qt 3 compatibility library for Qt 
ii  libqt4-sql                4.1.1-1        Qt 4 SQL database module
ii  libsm-dev                 6.9.0.dfsg.1-4 X Window System Session Management
ii  libx11-dev                6.9.0.dfsg.1-4 X Window System protocol client li
ii  libxcursor-dev            1.1.3-1        X cursor management library (devel
ii  libxext-dev               6.9.0.dfsg.1-4 X Window System miscellaneous exte
ii  libxft-dev            FreeType-based font drawing librar
ii  libxi-dev                 6.9.0.dfsg.1-4 X Window System Input extension li
ii  libxinerama-dev           6.9.0.dfsg.1-4 X Window System multi-head display
ii  libxmu-dev                6.9.0.dfsg.1-4 X Window System miscellaneous util
ii  libxrandr-dev             6.9.0.dfsg.1-4 X Window System Resize, Rotate and
ii  libxrender-dev            1:    X Rendering Extension client libra
ii  libxt-dev                 6.9.0.dfsg.1-4 X Toolkit Intrinsics development f
ii  x-dev                     6.9.0.dfsg.1-4 X protocol development files
ii  xlibmesa-gl-dev [libgl-de 6.9.0.dfsg.1-4 Mesa 3D graphics library developme
ii  xlibs-static-pic          6.9.0.dfsg.1-4 X Window System client extension l
ii  zlib1g-dev                1:1.2.3-11     compression library - development

Versions of packages libqt4-dev recommends:
ii  qt4-dev-tools                 4.1.1-1    Qt 4 development tools

-- debconf-show failed

--- End Message ---
--- Begin Message ---
Source: qt4-x11
Source-Version: 4.1.3-1

We believe that the bug you reported is fixed in the latest version of
qt4-x11, which is due to be installed in the Debian FTP archive:

  to pool/main/q/qt4-x11/libqt4-core_4.1.3-1_i386.deb
  to pool/main/q/qt4-x11/libqt4-debug-dev_4.1.3-1_i386.deb
  to pool/main/q/qt4-x11/libqt4-debug_4.1.3-1_i386.deb
  to pool/main/q/qt4-x11/libqt4-dev_4.1.3-1_i386.deb
  to pool/main/q/qt4-x11/libqt4-gui_4.1.3-1_i386.deb
  to pool/main/q/qt4-x11/libqt4-qt3support_4.1.3-1_i386.deb
  to pool/main/q/qt4-x11/libqt4-sql_4.1.3-1_i386.deb
  to pool/main/q/qt4-x11/qt4-designer_4.1.3-1_i386.deb
  to pool/main/q/qt4-x11/qt4-dev-tools_4.1.3-1_i386.deb
  to pool/main/q/qt4-x11/qt4-doc_4.1.3-1_all.deb
  to pool/main/q/qt4-x11/qt4-qtconfig_4.1.3-1_i386.deb
  to pool/main/q/qt4-x11/qt4-x11_4.1.3-1.diff.gz
  to pool/main/q/qt4-x11/qt4-x11_4.1.3-1.dsc
  to pool/main/q/qt4-x11/qt4-x11_4.1.3.orig.tar.gz

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 360802@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Brian Nelson <pyro@debian.org> (supplier of updated qt4-x11 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Sat,  3 Jun 2006 17:56:32 -0700
Source: qt4-x11
Binary: libqt4-sql libqt4-core qt4-doc libqt4-debug libqt4-qt3support qt4-designer libqt4-dev qt4-dev-tools libqt4-gui libqt4-debug-dev qt4-qtconfig
Architecture: source i386 all
Version: 4.1.3-1
Distribution: unstable
Urgency: high
Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Changed-By: Brian Nelson <pyro@debian.org>
 libqt4-core - Qt 4 core non-GUI functionality runtime library
 libqt4-debug - Qt 4 debugging runtime libraries
 libqt4-debug-dev - Qt 4 debugging development files
 libqt4-dev - Qt 4 development files
 libqt4-gui - Qt 4 core GUI functionality runtime library
 libqt4-qt3support - Qt 3 compatibility library for Qt 4
 libqt4-sql - Qt 4 SQL database module
 qt4-designer - Qt 4 Designer
 qt4-dev-tools - Qt 4 development tools
 qt4-doc    - Qt 4 API documentation
 qt4-qtconfig - Qt 4 configuration tool
Closes: 360802 368883
 qt4-x11 (4.1.3-1) unstable; urgency=high
   * New upstream release
   * debian/patches/16_hppa_ldcw_fix.dpatch: new patch from Ubuntu to
     properly support hppa
   * debian/patches/17_alpha_ice.dpatch: new patch from Steve Langasek to
     fix FTBFS on alpha (Closes: #368883)
     (urgency set to high for that fix).
   * Dropped the .la files since they pull in too many unneeded
     dependencies (Closes: #360802)
   * debian/libqt4-debug.install: removed
     usr/lib/qt4/plugins/codecs/*_debug.so since those aren't included
     upstream anymore
   * Increased standards version to 3.7.2
 e1a95ce65808d04b34383aa4023833db 1366 libs optional qt4-x11_4.1.3-1.dsc
 c6fc6934bfca458dde6e6370a2ed0101 32200887 libs optional qt4-x11_4.1.3.orig.tar.gz
 3b099de22afacc5d1a15fac704d55a05 19191 libs optional qt4-x11_4.1.3-1.diff.gz
 7566e611426681efa316566af1f4acd7 15939852 doc optional qt4-doc_4.1.3-1_all.deb
 a8aaffde90b90eb7de1f1a0ba1542b63 3858618 libdevel optional libqt4-dev_4.1.3-1_i386.deb
 078c6a14bb3d88b348d9fb79d3f9eb1b 289700 libdevel extra libqt4-debug-dev_4.1.3-1_i386.deb
 b47271ef906d77c9fe65623551078bb0 1248328 libs optional libqt4-core_4.1.3-1_i386.deb
 555225ef93f5768f752034916662096f 2518032 libs optional libqt4-gui_4.1.3-1_i386.deb
 9abbe70d17467f40bb4602a6bf739bde 313882 libs optional libqt4-sql_4.1.3-1_i386.deb
 b177be022aff2b5d22c2381d44bcd0d6 1261774 libs optional libqt4-qt3support_4.1.3-1_i386.deb
 56e96cd20f55ef802bf2b2e992cf45e0 2042456 devel optional qt4-designer_4.1.3-1_i386.deb
 7ebcd944cb7db4f76db254c2cafffdcc 51217774 libs optional libqt4-debug_4.1.3-1_i386.deb
 fbf6cc445379eb1b3438651e65c791a5 539528 devel optional qt4-dev-tools_4.1.3-1_i386.deb
 19432edd8ddb3acbe688234ee84edbf2 104580 x11 optional qt4-qtconfig_4.1.3-1_i386.deb

Version: GnuPG v1.4.3 (GNU/Linux)


--- End Message ---

Reply to: