[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#358723: marked as done (kdepim: Strange dependency problems: crashes, FTBFS)

Your message dated Thu, 13 Apr 2006 04:13:58 -0500
with message-id <200604130413.58198.adam@alphapapa.net>
and subject line Obsoleted by 3.5.2?  Closing.
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: kdepim
Version: 4:3.4.3-1
Severity: normal

Hash: SHA1

Suddenly after a recent upgrade, my KMail (3.4.3-1, aka v1.8.3) crashes (with no KDE crash handler/debugger) if I:

a)  start typing in the "To" field in a new message
     "kmail: symbol lookup error: /usr/lib/libkmailprivate.so: undefined symbol: _ZN4KPIM17AddresseeLineEdit10addContactERKN4KABC9AddresseeEi"
b)  try to drag a message from a list of messages in a folder (it happens as soon as I drag the cursor after pressing the mouse button).
     "kmail: symbol lookup error: /usr/lib/libkmailprivate.so: undefined symbol: _ZN4KPIM12MailListDragC1E10QValueListINS_11MailSummaryEEP7QWidget"

Months ago, when I was switching between KDE-PIM 3.4.3 and 3.5.1 (because of other KMail problems), I had similar problems.  I solved these crashes at one time by 
recompiling kdepim myself.  However, when I try to build them with apt-build now, I get this:

/var/cache/apt-build/build/kdepim-3.4.3/build-tree/kdepim-3.4.3/kontact/plugins/specialdates/sdsummarywidget.cpp: In member function 'void SDSummaryWidget::updateView()':
/var/cache/apt-build/build/kdepim-3.4.3/build-tree/kdepim-3.4.3/kontact/plugins/specialdates/sdsummarywidget.cpp:453: error: no matching function for call to 
'KURLLabel::setSizePolicy(QSizePolicy::SizeType, QSizePolicy::SizeType)'
/usr/include/kde/kurllabel.h:169: note: candidates are: virtual void KURLLabel::setSizePolicy(QSizePolicy)

kurllabel.h comes from kdelibs4-dev.

$ acp kdelibs4-dev
  Installed: 4:3.5.1-4
  Candidate: 4:3.5.1-4
  Version table:
 *** 4:3.5.1-4 0
        600 http://ftp.us.debian.org unstable/main Packages
        100 /var/lib/dpkg/status
     4:3.5.1-2 0
        650 http://ftp.us.debian.org testing/main Packages

$ sa install kdelibs4-dev/testing
The following packages have unmet dependencies:
  kdelibs4-dev: Depends: kdelibs4c2a (= 4:3.5.1-2) but 4:3.5.1-4 is installed.
                Depends: kdelibs-bin (= 4:3.5.1-2) but 4:3.5.1-4 is installed.

Trying to downgrade all that to /testing causes apt to want to remove all of kdepim!

I admit I'm running a combination of testing and unstable, but from my limited knowledge, this seems like dependency problems.  I'm going to try removing all that and 
reinstalling, but I thought I should file a bug.

- -- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (650, 'testing'), (600, 'unstable'), (500, 'stable'), (1, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.15-1-k7
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=ISO-8859-1)

Version: GnuPG v1.4.2.2 (GNU/Linux)


--- End Message ---
--- Begin Message ---
Since 3.5.2 is out now, I'm going to go ahead and close this.

--- End Message ---

Reply to: