[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#293494: kio_audio prevents eject'ing of cdrom



found 284853 kdemultimedia-kio-plugins 3.5.2-2
thanks

Le Mar 11 Avril 2006 22:24, Patrick Cornelißen a écrit :
> Fathi Boudra wrote:
> > It seems that a user is affected with this bug in latest 3.5.2 so
the user is me

> > further investigations/tests are needed before closing it.
>
> Hmm, the bug  is caused by a missing close statement in the kio
> slave, it has been fixed and put in their CVS, are you sure it's on
> 3.5.x too?

I've not verified if the patch is applied but I have 3.5.2-2 
kdemultimedia-kio-plugins and if I insert an audio CD, my "removable 
device" applet shows almost instantely that I have a media CD (that is 
good) and If I try to use its "eject" command, it does not work

it does not works from konqueror either.

lsof says :

[madcoder hades] lsof /dev/hda
lsof: WARNING: can't stat() ext3 file system /dev/.static/dev
      Output information may be incomplete.
COMMAND    PID     USER   FD   TYPE DEVICE SIZE NODE NAME
kio_audio 5338 madcoder   14r   BLK    3,0      8832 /dev/hda
kio_audio 5339 madcoder   14r   BLK    3,0      8832 /dev/hda
kio_audio 5368 madcoder   14r   BLK    3,0      8832 /dev/hda


I have to killall kio_audiocd and that works.


with a "data" cd it works correctly.
-- 
·O·  Pierre Habouzit
··O                                                madcoder@debian.org
OOO                                                http://www.madism.org

Attachment: pgpBWAto1_9Jc.pgp
Description: PGP signature


Reply to: