[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#360311: Krita lacks all tablet support.

Alright.. I figured out what was going on. Turned out I was being a bit
of a moron.

What I needed to do was go into settings --> configure Krita --> tablet
support.. then enable detection for the 3 controllers.

I didn't figure this out until I tried to disable the X.org
configuration for my mouse and made the pen the 'Core Pointer' device.
Then that worked.. but without the pressure senstivity stuff. Then while
messing around with the settings I found the tablet settings and enabled
detection for the 'stylus' (the wacom mouse) and 'eraser'..

Of course then when I tried to use the erasor it promptly crashed krita.
(and apparently the kde bug helper thingy that popped up afterwards. or
at least it closed very very quickly) After a few times crashing krita
in that way I got a bit smarter then restored my original X.org
configuration, restarted gdm, then configured detection for the stylus.

After that then it worked fine.

Apparently without the detection stuff enabled Krita would interpret the
mouse touching the pad as a 'click' and make a dot.. which was the
beginning of a line. It wasn't picking up me moving the pen around on
the surface of the tablet for some reason.. Then when I jostled the
computer desk slightly my optical mouse would move slightly and then
krita would think that was me moving it or whatever from the original
'dot' and then that were those long lines were sometimes coming from. 

Otherwise krita wasn't picking up on it being moved.

However once I configured it to detect the stylus and such then
everythign works perfectly... and indeed the pressure sensitivity is
very nicely done!

My only suggestion would be to allow the tablet to work even when Krita
is setup not to detect the extra features. There is something weird with
that. Normally I have no problem using the stylus as a mouse even with
apps that have no detection features... it just treats them like a
normal mouse. With Gimp it worked out of the box similar to a normal
mouse, but you have to go into the "Configure Extended Input devices"
dialog in it's file --> preferences menu to get the extra features like
pressure sensitivity working.

Thank you for your time and sorry for any confusion I caused.

BTW. I am not using any odd wacom drivers or whatnot. I am just using
the ones supplied by default with the current X.org install and the
2.6.15 kernel I am using.

Here is my X.org configuration, which may show any mistakes I made with

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse" "CorePointer"
    InputDevice    "stylus"    "SendCoreEvents"
    InputDevice    "eraser"    "SendCoreEvents"
    InputDevice    "cursor"    "SendCoreEvents"    #

Section "Files"
			# local font server
	# if the local font server has problems, we can fall back on these
    FontPath        "unix/:7100"
    FontPath        "/usr/lib/X11/fonts/misc"
    FontPath        "/usr/lib/X11/fonts/cyrillic"
    FontPath        "/usr/lib/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/lib/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/lib/X11/fonts/Type1"
    FontPath        "/usr/lib/X11/fonts/CID"
    FontPath        "/usr/lib/X11/fonts/100dpi"
    FontPath        "/usr/lib/X11/fonts/75dpi"

Section "Module"
    Load           "bitmap"
    Load           "dbe"
    Load           "ddc"
    Load           "extmod"
    Load           "freetype"
    Load           "glx"
    Load           "int10"
    Load           "record"
    Load           "type1"
    Load           "v4l"
    Load           "vbe"

Section "InputDevice"
    Identifier     "Generic Keyboard"
    Driver         "keyboard"
    Option         "CoreKeyboard"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc104"
    Option         "XkbLayout" "us"

#Section "InputDevice"
#    Identifier     "Configured Mouse"
#    Driver         "mouse"
#    Option 	"CorePointer"
#    #Option	"Name" "Microso*"
#    #Option         "Buttons" "13"
#    #Option 	"Driver" "ImPS/2"
#    Option	"Device"	"/dev/input/mouse1"
#    Option	"Emulate3Buttons" "No"
#    Option	"Protocol"	"ExplorerPS/2"
#    Option      "ZAxisMapping" "4 5"

Section "InputDevice"
    Identifier     "Configured Mouse"
    Driver         "evdev"
    Option 	"CorePointer"
    Option	"Name" "Logitech USB RECEIVER"
    #Option         "Buttons" "13"
    Option	"Device"	"/dev/input/event0"

Section "InputDevice"
  Driver        "wacom"
  Identifier    "stylus"
  Option 	"CorePointer"
  Option        "Device"        "/dev/input/event4"   # USB ONLY
  Option        "Type"          "stylus"
  Option        "USB"           "on"                  # USB ONLY

Section "InputDevice"
  Driver        "wacom"
  Identifier    "eraser"
  Option        "Device"        "/dev/input/event4"   # USB ONLY
  Option        "Type"          "eraser"
  Option        "USB"           "on"                  # USB ONLY

Section "InputDevice"
  Driver        "wacom"
  Identifier    "cursor"
  Option        "Device"        "/dev/input/event4"   # USB ONLY
  Option        "Type"          "cursor"
  Option        "USB"           "on"                  # USB ONLY

Section "Monitor"
    Identifier     "Generic Monitor"
    HorizSync       30.0 - 96.0
    VertRefresh     50.0 - 160.0
    Option         "DPMS"

Section "Device"
    #BusID   "PCI:1:0:0"
    Identifier     "NVIDIA Corporation NV35 [GeForce FX 5900]"
    Driver         "nvidia"

Section "Screen"
    Identifier     "Default Screen"
    Device         "NVIDIA Corporation NV35 [GeForce FX 5900]"
    Monitor        "Generic Monitor"
    DefaultDepth    24
    SubSection     "Display"
        Depth       1
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
    SubSection     "Display"
        Depth       4
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
    SubSection     "Display"
        Depth       8
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
    SubSection     "Display"
        Depth       15
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
    SubSection     "Display"
        Depth       16
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
    SubSection     "Display"
        Depth       24
        Modes      "1280x1024" "1024x768" "800x600" "640x480"

Reply to: