[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[neroden@twcny.rr.com: cppunit: FTBFS on hppa]

Hello HPPA and Qt folks,

Could someone help me out with BTS 341675?  

Suddenly the "uic" program from Qt fails to run on the hppa build
daemon.  There is no relevant source change in cppunit between
revision -4 (which built on September 7) and revision -5.  The build
log shows that it runs into an illegal instruction.  I ran the command
by hand on paer and indeed "uic" quits with SIGILL.  I ran it in the
debugger and it looks like a problem in libgcc_s.so.  Could someone
confirm whether this is the case?

Or perhaps it is actually a problem in qt3's "uic"?  That comes from
package qt3-dev-tools.  The successful september build used


but this time it is



Here's the GDB run:

smr@paer:~/cppunit-1.10.2/src/qttestrunner$ gdb /usr/share/qt3/bin/uic
GNU gdb 6.3-debian
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "hppa-linux"...(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".

(gdb) set arg testbrowserdlg.ui -o testbrowserdlg.h
(gdb) run
Starting program: /usr/share/qt3/bin/uic testbrowserdlg.ui -o testbrowserdlg.h
[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 29152)]
Qt: gdb: -nograb added to command-line options.
         Use the -dograb option to enforce grabbing.

Program received signal SIGILL, Illegal instruction.
[Switching to Thread 16384 (LWP 29152)]
0x4200f534 in __umoddi3 () from /lib/libgcc_s.so.2
(gdb) bt
#0  0x4200f534 in __umoddi3 () from /lib/libgcc_s.so.2
#1  0x40f1ca84 in QLocalePrivate::isDigit () from /usr/lib/libqt-mt.so.3
#2  0x40f1cd10 in QLocalePrivate::isDigit () from /usr/lib/libqt-mt.so.3
#3  0x40f1d8d8 in QLocalePrivate::longLongToString () from /usr/lib/libqt-mt.so.3
#4  0x40f3e8a8 in QString::setNum () from /usr/lib/libqt-mt.so.3
#5  0x40f462e4 in QString::setNum () from /usr/lib/libqt-mt.so.3
#6  0x40e3809c in QDomElement::setAttribute () from /usr/lib/libqt-mt.so.3
#7  0x40e38128 in QDomElement::setAttribute () from /usr/lib/libqt-mt.so.3
#8  0x0005ea18 in QCleanupHandler<QPluginManager<QWidgetFactoryInterface> >::~QCleanupHandler ()
#9  0x0001d2a0 in main ()

Here's the original bug report:

----- Forwarded message from Nathanael Nerode <neroden@twcny.rr.com> -----

From: Nathanael Nerode <neroden@twcny.rr.com>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: cppunit: FTBFS on hppa
Date: Fri, 02 Dec 2005 00:11:22 -0500

Package: cppunit
Version: 1.10.2-5
Severity: serious
Justification: fails to build from source

Build log is at

The relevant bit is:

cd src/qttestrunner && qmake qttestrunner.pro
/usr/bin/make -C src/qttestrunner
make[1]: Entering directory `/build/buildd/cppunit-1.10.2/src/qttestrunner'
/usr/share/qt3/bin/uic testbrowserdlg.ui -o testbrowserdlg.h
make[1]: *** [testbrowserdlg.h] Illegal instruction
make[1]: *** Deleting file `testbrowserdlg.h'
make[1]: Leaving directory `/build/buildd/cppunit-1.10.2/src/qttestrunner'
make: *** [build-stamp] Error 2

This doesn't look like your fault.

----- End forwarded message -----

Reply to: