[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#317768: marked as done (qt3-designer: qt3 programs does not compile with g++4.0)

Your message dated Tue, 09 Aug 2005 14:31:16 -0700
with message-id <E1E2bgq-0007KU-00@spohr.debian.org>
and subject line Bug#317768: fixed in qt-x11-free 3:3.3.4-4
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 11 Jul 2005 12:02:28 +0000
>From md6604@mclink.it Mon Jul 11 05:02:28 2005
Return-path: <md6604@mclink.it>
Received: from mail1.mclink.it [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1DrwzU-0006IV-00; Mon, 11 Jul 2005 05:02:28 -0700
Received: from localhost.localdomain (81-208-36-84.fastres.net [])
	by mail1.mclink.it (8.12.6p2/8.12.3) with ESMTP id j6BC2NK7073155;
	Mon, 11 Jul 2005 14:02:23 +0200 (CEST)
	(envelope-from md6604@mclink.it)
Message-Id: <200507111202.j6BC2NK7073155@mail1.mclink.it>
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: Michele <md6604@mclink.it>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: qt3-designer: qt3 programs does not compile with g++4.0
X-Mailer: reportbug 3.15
Date: Mon, 11 Jul 2005 14:02:18 +0200
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-3.8 required=4.0 tests=BAYES_00,FROM_ENDS_IN_NUMS,
	autolearn=no version=2.60-bugs.debian.org_2005_01_02

Package: qt3-designer
Version: 3:3.3.4-3
Severity: important

After updating the system with apt-get update and the release of new g++
the program still look for libstdc++.so.5 whenever a new version
libstdc++.so.6 is available. I am new on programming on Linux and QT, so
I think that recompiling the qt3-designer from source could be enough
but I will try as soon I will have time. At the moment, the qt3-designer
works 100% but when I try to compile the code autogenerated, at the
moment of linking ld emits a warning claiming that
/usr/share/qt3/lib/libqt-mt.so may conflict with libstdc++.so.6. On my
system, that library is dinamically linked by default with
libstdc++.s0.5. After it there is an undefined reference to main and the
linking stop

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.4.27-2-386
Locale: LANG=it_IT@euro, LC_CTYPE=it_IT@euro (charmap=ISO-8859-15)

Versions of packages qt3-designer depends on:
ii  libc6                    2.3.2.ds1-22    GNU C Library: Shared libraries an
ii  libfontconfig1           2.3.2-1         generic font configuration library
ii  libfreetype6             2.1.10-1        FreeType 2 font engine, shared lib
ii  libgcc1                  1:4.0.1-1       GCC support library
ii  libice6                  4.3.0.dfsg.1-14 Inter-Client Exchange library
ii  libpng12-0               1.2.8rel-1      PNG library - runtime
ii  libqt3c102-mt            3:3.3.4-3       Qt GUI Library (Threaded runtime v
ii  libsm6                   4.3.0.dfsg.1-14 X Window System Session Management
ii  libstdc++5               1:3.3.6-7       The GNU Standard C++ Library v3
ii  libx11-6                 4.3.0.dfsg.1-14 X Window System protocol client li
ii  libxcursor1              1.1.3-1         X cursor management library
ii  libxext6                 4.3.0.dfsg.1-14 X Window System miscellaneous exte
ii  libxft2                  2.1.7-1         FreeType-based font drawing librar
ii  libxrandr2               4.3.0.dfsg.1-14 X Window System Resize, Rotate and
ii  libxrender1              1:0.9.0-2       X Rendering Extension client libra
ii  xlibs                    4.3.0.dfsg.1-14 X Keyboard Extension (XKB) configu
ii  zlib1g                   1:1.2.2-8       compression library - runtime

Versions of packages qt3-designer recommends:
ii  qt3-dev-tools                 3:3.3.4-3  Qt3 development tools

-- no debconf information

Received: (at 317768-close) by bugs.debian.org; 9 Aug 2005 21:38:48 +0000
>From joerg@spohr.debian.org Tue Aug 09 14:38:48 2005
Return-path: <joerg@spohr.debian.org>
Received: from joerg by spohr.debian.org with local (Exim 3.36 1 (Debian))
	id 1E2bgq-0007KU-00; Tue, 09 Aug 2005 14:31:16 -0700
From: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
To: 317768-close@bugs.debian.org
X-Katie: lisa $Revision: 1.30 $
Subject: Bug#317768: fixed in qt-x11-free 3:3.3.4-4
Message-Id: <E1E2bgq-0007KU-00@spohr.debian.org>
Sender: Joerg Jaspert <joerg@spohr.debian.org>
Date: Tue, 09 Aug 2005 14:31:16 -0700
Delivered-To: 317768-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02
X-CrossAssassin-Score: 9

Source: qt-x11-free
Source-Version: 3:3.3.4-4

We believe that the bug you reported is fixed in the latest version of
qt-x11-free, which is due to be installed in the Debian FTP archive:

  to pool/main/q/qt-x11-free/libqt3-compat-headers_3.3.4-4_i386.deb
  to pool/main/q/qt-x11-free/libqt3-dev_3.3.4-4_i386.deb
  to pool/main/q/qt-x11-free/libqt3-headers_3.3.4-4_i386.deb
  to pool/main/q/qt-x11-free/libqt3-i18n_3.3.4-4_all.deb
  to pool/main/q/qt-x11-free/libqt3-mt-dev_3.3.4-4_i386.deb
  to pool/main/q/qt-x11-free/libqt3-mt-mysql_3.3.4-4_i386.deb
  to pool/main/q/qt-x11-free/libqt3-mt-odbc_3.3.4-4_i386.deb
  to pool/main/q/qt-x11-free/libqt3-mt-psql_3.3.4-4_i386.deb
  to pool/main/q/qt-x11-free/libqt3-mt-sqlite_3.3.4-4_i386.deb
  to pool/main/q/qt-x11-free/libqt3-mt_3.3.4-4_i386.deb
  to pool/main/q/qt-x11-free/libqt3-mysql_3.3.4-4_i386.deb
  to pool/main/q/qt-x11-free/libqt3-odbc_3.3.4-4_i386.deb
  to pool/main/q/qt-x11-free/libqt3-psql_3.3.4-4_i386.deb
  to pool/main/q/qt-x11-free/libqt3-sqlite_3.3.4-4_i386.deb
  to pool/main/q/qt-x11-free/libqt3_3.3.4-4_i386.deb
  to pool/main/q/qt-x11-free/qt-x11-free_3.3.4-4.diff.gz
  to pool/main/q/qt-x11-free/qt-x11-free_3.3.4-4.dsc
  to pool/main/q/qt-x11-free/qt3-apps-dev_3.3.4-4_i386.deb
  to pool/main/q/qt-x11-free/qt3-assistant_3.3.4-4_i386.deb
  to pool/main/q/qt-x11-free/qt3-designer_3.3.4-4_i386.deb
  to pool/main/q/qt-x11-free/qt3-dev-tools-compat_3.3.4-4_i386.deb
  to pool/main/q/qt-x11-free/qt3-dev-tools-embedded_3.3.4-4_i386.deb
  to pool/main/q/qt-x11-free/qt3-dev-tools_3.3.4-4_i386.deb
  to pool/main/q/qt-x11-free/qt3-doc_3.3.4-4_all.deb
  to pool/main/q/qt-x11-free/qt3-examples_3.3.4-4_all.deb
  to pool/main/q/qt-x11-free/qt3-linguist_3.3.4-4_i386.deb
  to pool/main/q/qt-x11-free/qt3-qtconfig_3.3.4-4_i386.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 317768@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org> (supplier of updated qt-x11-free package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Tue, 26 Jul 2005 19:06:03 +0200
Source: qt-x11-free
Binary: libqt3-mysql libqt3-i18n libqt3 qt3-apps-dev libqt3-mt-sqlite libqt3-ibase qt3-assistant qt3-examples qt3-doc libqt3-headers libqt3-mt-mysql libqt3-mt libqt3-odbc libqt3-mt-odbc qt3-dev-tools-embedded libqt3-compat-headers libqt3-dev qt3-dev-tools libqt3-mt-ibase libqt3-sqlite qt3-designer qt3-linguist libqt3-psql qt3-qtconfig qt3-dev-tools-compat libqt3-mt-psql libqt3-mt-dev
Architecture: source i386 all
Version: 3:3.3.4-4
Distribution: unstable
Urgency: low
Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Changed-By: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
 libqt3     - Qt GUI Library, Version 3
 libqt3-compat-headers - Qt 1.x and 2.x compatibility includes
 libqt3-dev - Qt development files
 libqt3-headers - Qt3 header files
 libqt3-i18n - i18n files for Qt3 library
 libqt3-mt  - Qt GUI Library (Threaded runtime version), Version 3
 libqt3-mt-dev - Qt development files (Threaded)
 libqt3-mt-mysql - MySQL database driver for Qt3 (Threaded)
 libqt3-mt-odbc - ODBC database driver for Qt3 (Threaded)
 libqt3-mt-psql - PostgreSQL database driver for Qt3 (Threaded)
 libqt3-mt-sqlite - SQLite database driver for Qt3 (Threaded)
 libqt3-mysql - MySQL database driver for Qt3
 libqt3-odbc - ODBC database driver for Qt3
 libqt3-psql - PostgreSQL database driver for Qt3
 libqt3-sqlite - SQLite database driver for Qt3
 qt3-apps-dev - Qt3 Developer applications development files
 qt3-assistant - The Qt3 assistant application
 qt3-designer - Qt3 Designer
 qt3-dev-tools - Qt3 development tools
 qt3-dev-tools-compat - Conversion utilities for Qt3 development
 qt3-dev-tools-embedded - Tools to develop embedded Qt applications
 qt3-doc    - Qt3 API documentation
 qt3-examples - Examples for Qt3
 qt3-linguist - The Qt3 Linguist
 qt3-qtconfig - The Qt3 Configuration Application
Closes: 182366 268882 282217 290402 303065 305919 311562 317500 317768 319305
 qt-x11-free (3:3.3.4-4) unstable; urgency=low
   * The "Three transitions and one maintainer switch" release.
   * Cope with the following ongoing transitions in unstable:
     - C++ ABI transition.
     - X.org transition.
     - PostgreSQL 8.0 transition.
   * Move the package to the Debian Qt/KDE team, as agreed with the
     maintainer. Thanks to Martin Loschwitz for all his work over the
   +++ Changes by Adeodato Simó:
   * Transition to the new C++ ABI. Rename all the library packages as
     necessary: every libqt3c102-* goes back to libqt3-* now. Changes based
     on the patch provided by Matthias Klose in Ubuntu Bug 10723.
     + debian/control:
       - renamed library packages.
       - add conflicts and replaces against the libqt3c102-* packages, or
         change the existing libqt3-* ones.
       - change the existing recommends and suggests on libqt3c102-* to
       - adjusted descriptions where appropriate.
     + debian/rules:
       - s/c102// in various places.
     + debian/*.install, debian/*.links:
       - renamed as appropriate.
     + debian/patches/31_gcc4_buildkey.dpatch:
       - new patch picked from the Fedora Qt packages to ensure a stable
         buildkey accross compiler upgrades now that GCC 4 is the default.
         Kudos to Christopher Martin for finding about the existence of this
     The above solves trouble for users when using qt3-designer with g++ 4.0,
     so this upload closes: #317768.
     Also, disabling InterBase support has been necessary in this upload,
     because nobody has cared to make firebird2 not FTBFS with g++ 4.0. Dropped
     the libqt3-ibase and libqt3-mt-ibase packages, which can be reintroduced
     as soon as #317314 gets fixed.
       + debian/control:
         - don't build-depend on firebird2-dev.
       + debian/rules:
         - unconditionally use -no-sql-ibase and -Nlibqt3{,-mt}-ibase.
   * Transition to the new X.org packages:
     + debian/control:
       - build-depend in libglu1-xorg-dev instead of xlibmesa-glu-dev; make the
         same change in the dependencies of libqt3-dev and libqt3-mt-dev.
       - add libxinerama-dev and libxkbfile-dev to build-dependencies; add
         libxinerama-dev to the dependencies of libqt3-dev and libqt3-mt-dev as
         well (closes: #319305).
       - add libxi-dev to the dependencies of libqt3-dev and libqt3-mt-dev. [cm]
   * Transition to the new PostgreSQL 8.0 packaging (closes: #317500):
     + debian/control: build-depend on libpq-dev instead of postgresql-dev.
     + debian/rules: invoke pg_config to determine the include directory.
   * Don't modify debian/control at build time, since doing it in the clean
     target it's a release critical bug now:
     + debian/rules: don't invoke type-handling to generate debian/control.
     + debian/control.in: removed.
     + debian/control:
       - adjust the list of *-i386 ports to list only the non-dead ones.
       - don't build depend on type-handling.
   * Overhaul arch detection in debian/rules:
     - use DEB_HOST_ARCH instead of DEB_BUILD_GNU_CPU to detect arm.
     - use DEB_HOST_ARCH_CPU instead of DEB_BUILD_GNU_CPU to detect an i386 CPU
       (needs the new dpkg).
   +++ Changes by Christopher Martin:
   * Add sundry fixes from KDE's qt-copy. (Closes: #303065)
   * Fix qt3-designer's appearance in the KDE menu. (Closes: #290402)
   * Don't use lib64 on amd64. (Closes: #311562)
   * Don't duplicate the information in the qvfb manpage. (Closes: #282217)
     While we're at it, realize that a whole bunch of manpages were suffering
     the same, and fix them (designer, makeqpf, mergetr, findtr, msg2qm,
     qtconfig, createcw, qembed, qt20fix). [dato]
   * Add linguist manpage. Thanks to Jeremy Laine. (Closes: #268882)
   * Include createcw source for qt3-designer. (Closes: #305919)
   * Add missing qvfbhdr.h. (Closes: #182366, the qinterlacestyle.h
     mentioned in this bug report was already included in recent versions.)
   * Many minor changes to improve lintian compliance.
   * Bump Standards-Version to 3.6.2 (no changes required).
 daf236941c0ce28853fc91ff54cf9b1f 1888 libs optional qt-x11-free_3.3.4-4.dsc
 1b582d10d939334593c08b28c48a52e9 64526 libs optional qt-x11-free_3.3.4-4.diff.gz
 e290a222e3551893606e4c720f118352 93484 libs optional libqt3-i18n_3.3.4-4_all.deb
 6447d0537f8b48bf0f387e7efbd3f1bf 5612378 doc extra qt3-doc_3.3.4-4_all.deb
 8176a21ec8ddeb17902efb84c44cb7a8 1553544 doc extra qt3-examples_3.3.4-4_all.deb
 8bd124b07cde2a101edab0351c238de6 2809582 libs optional libqt3_3.3.4-4_i386.deb
 35eb9e98392ac722cb24830d42909172 2913180 libs optional libqt3-mt_3.3.4-4_i386.deb
 8b672ec43c93a7134a2ffd74c8f8d401 46932 libs optional libqt3-mysql_3.3.4-4_i386.deb
 8744071d79b37ad11b4f55d463521557 46826 libs optional libqt3-mt-mysql_3.3.4-4_i386.deb
 d635e39543f6a8baddba94064f473e73 63896 libs optional libqt3-odbc_3.3.4-4_i386.deb
 63dfdc69f18c5e8e05916556c1eecb4c 63770 libs optional libqt3-mt-odbc_3.3.4-4_i386.deb
 27bc7e3cf002f6cd28a184d25df22711 53546 libs optional libqt3-psql_3.3.4-4_i386.deb
 cb0f1dd96a0c6e42dd5c82eeae2129f1 53422 libs optional libqt3-mt-psql_3.3.4-4_i386.deb
 11bd191b054aa7b7532e908226ad942e 208134 libs optional libqt3-sqlite_3.3.4-4_i386.deb
 cc193e01f466c81241950219b3f2eff7 208006 libs optional libqt3-mt-sqlite_3.3.4-4_i386.deb
 9385fe274a8e93a47968bf0d1b3e855b 41828 libdevel optional libqt3-dev_3.3.4-4_i386.deb
 81c867f522fcf9d2eb174517336b41b8 48096 libdevel optional libqt3-mt-dev_3.3.4-4_i386.deb
 57ae990a990f4eb6c020507a41e6dc83 361978 devel optional libqt3-headers_3.3.4-4_i386.deb
 05f577768169366709b8cee777f5b984 79444 devel optional libqt3-compat-headers_3.3.4-4_i386.deb
 80ab08b752a8dd709e5c12b3d4f50fec 1264542 devel optional qt3-dev-tools_3.3.4-4_i386.deb
 3aa35f36d7c2278d9880712663d725bc 4039438 devel optional qt3-designer_3.3.4-4_i386.deb
 91390309ecf892a2ee8afe165fc65603 2013916 devel optional qt3-apps-dev_3.3.4-4_i386.deb
 2f900a7a057686762912f81f0a53ae43 332222 devel optional qt3-linguist_3.3.4-4_i386.deb
 ca7e93413090cdfbb7e12f8d94f8df19 233526 x11 optional qt3-assistant_3.3.4-4_i386.deb
 8e49955fa38ff7ddae0156a813314b83 91384 x11 optional qt3-qtconfig_3.3.4-4_i386.deb
 4bdabf9f72104566b55f8c1da089c547 281938 devel optional qt3-dev-tools-embedded_3.3.4-4_i386.deb
 01e188629614b1b1b70dbe9f8105567e 66034 devel optional qt3-dev-tools-compat_3.3.4-4_i386.deb

Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Signed by Adeodato Simó <asp16@alu.ua.es>


Reply to: