[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: A Prisonner of the dependency hell

On Fri, May 27, 2005 at 04:49:14PM -0700, Steve Langasek wrote:
> On Sat, May 28, 2005 at 01:03:13AM +0200, Bill Allombert wrote:
> > I need to attract your attention on bug #310490.
> > This show a pure woody system that cannot be upgraded to sarge
> > using the recommended way witout basically removing KDE.
> > This bug is 100% reproducible, but I have not yet completly
> > tracked the problem, though I have seen pretty awkward behaviour from
> > apt. In particular 'apt-get install fontconfig' fails with a message
> > claiming that defoma cannot installed while defoma is up-to-date.
> > Upgrading with dselect work much better.
> > I did not try yet to upgrade using aptitude in interactive mode.
> I don't suppose there's a smaller test case involving fewer packages?

OK, I have done that:
1) debootstrap woody
2) install konqueror,libqt3 and aptitude
3) move to sarge
aptitude -f dist-upgrade want to remove konqueror

Bill. <ballombe@debian.org>

Imagine a large red swirl here. 

Reply to: