[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#304147: kiconedit: crashes with SIGSEGV on start-up



On Monday 11 April 2005 12:08 pm, Riku Voipio wrote:
> On Mon, Apr 11, 2005 at 09:48:26AM +0100, Neil Williams wrote:
> > Loading kiconedit from the menu causes a SIGSEGV as soon
> > as the window tries to display. The window then closes
> > and the KDE crash handler appears.

> unreproducible on sarge. same version of package in sid too.
> Try moving ./.kde/share/config/kiconeditrc somewhere else, or
> try using kiconedit with a fresh new user account.

Moving the RC file did the trick for console opening but NOT the menu! That 
still seg faults. Even after logging out and back in, it still seg faults from 
the menu! (And once it HAS seg faulted from the menu, it no longer works from 
the console!)

This is the diff of the new vs old:

--- /home/neil/kiconeditrc      2004-09-12 19:43:26.000000000 +0100
+++ /home/neil/.kde/share/config/kiconeditrc    2005-04-11 14:40:43.000000000 
+0100
@@ -14,16 +14,6 @@ ShowRulers=true
 TransparencyDisplayType=Checkerboard
 TransparencySolidColor=255,255,255

-[KFileDialog Settings]
-Automatic Preview=true
-Preview Size=60
-Recent Files=/usr/share/icons/kdeclassic/16x16/actions/colorize.png
-ShowPreviews=false
-ViewMode=SmallColumns
-
-[KFileDialog Speedbar]
-Speedbar IconSize=22
-
 [MainWindowSettings Toolbar mainToolBar]
 Index=0

@@ -37,7 +27,3 @@ Position=Right
 [MainWindowSettings Toolbar toolsToolBar]
 IconText=IconOnly
 Index=0
-
-[RecentFiles]
-File1=file:/usr/share/apps/kiconedit/pics/standard.png
-File2=file:/usr/share/icons/kdeclassic/16x16/actions/colorize.png


> > Versions of packages kiconedit depends on:
> > ii  kdelibs4             4:3.3.2-4.0.2       KDE core libraries
>
> Where is that version from? debian does not have such version of kdelibs

?? Debian unstable does:
http://packages.debian.org/unstable/libs/kdelibs4
4:3.3.2-4.0.2 [i386]

Are you comparing against a different architecture?

> > ii  libice6              4.3.0.dfsg.1-12.0.1 Inter-Client Exchange
> > library ii  libsm6               4.3.0.dfsg.1-12.0.1 X Window System
> > Session Management ii  libx11-6             4.3.0.dfsg.1-12.0.1 X Window
> > System protocol client li ii  libxext6             4.3.0.dfsg.1-12.0.1 X
> > Window System miscellaneous exte ii  xlibs                4.3.0.dfsg.1-12
> >     X Keyboard Extension (XKB) configu
>
> Ditto for your X version.

All standard Debian unstable (sid). I don't use any non-standard mirrors.

-- 

Neil Williams
=============
http://www.dcglug.org.uk/
http://www.nosoftwarepatents.com/
http://www.linux.codehelp.co.uk/

Attachment: pgpTtHwHNOyi5.pgp
Description: PGP signature


Reply to: