[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#267016: kopete: cannot change to another IRC-network in existing account

Am Samstag, 21. August 2004 00:27 schrieben Sie:
> tag 267016 moreinfo
> quit
> * Michael Wieserner [Fri, 20 Aug 2004 10:25:51 +0200]:
>   hi Michael,
> > After renaming my standard network i added to kopete because it wasn't by
> > default available, kopete wasn't able to access the network. Even by
> > explicitly selecting it in the IRC account options didn't change anything
> > (maybe because the old network name isn't available anymore?).
> >
> > So I had to edit kopeterc manually and change the network name there by
> > myself but don't have any problems now.
>   for any chance of getting this fixed, please provide the detailed
>   steps to reproduce:
>     - which network did you create (name and settings)
>     - if it worked fine just after creating, and if you restarted kopete
>       before changing the name
>     - steps you followed to change the name and which new name you gave
>       to it
>   otherwise, we lack the time to do all that investigation by ourselves.
>   thanks,


I tried again and that's what I did: 

I created a new network without any name given including one server 
(irc.quakenet.org:6667), the network was named "New Network" (standard). 

Login proceeds without problems but now I see that I want to rename the 
network name to QuakeNet (I tried some other names -> exchangeable). Rename 
the network, change your IRC account settings to use the new network name 
(made automatically actually).

Problem in two different versions: 

1. Re-login directly after changing name and logout from IRC network does 
absolutely nothing. The IRC icon blinks but stops after a few seconds without 
any error notice.

2. After restarting kopete, error message pops up: 

"The network associated with this account, New Network, no longer exists. 
Please ensure that the account has a valid network. The account will not be 
enabled until you do so."

You can check the preferences again to change the network name but it doesn't 
help. Manually editing kopeterc or just creating a new IRC account solves the 
problem which is IMHO no clean solution.

I have reproduced the bug three times now, one time restarting kopete beforce 
changing the network name and the other time without restarting. Both lead to 
the same result.

Politics and the fate of mankind are formed by men without ideals and without
greatness.  Those who have greatness within them do not go in for politics.
                -- Albert Camus

Reply to: